aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-06-20 12:33:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-20 12:33:07 +0200
commitc8aa4b10b2ab341bbcb163d041c44c1a20172ee1 (patch)
tree773f4205905ac2dd2fbc1c12ab45a06bedbcbafd /meta-oe/recipes-devtools
parentc47471a1776d8616b5e4874e238a03c6f9feac08 (diff)
downloadmeta-openembedded-contrib-c8aa4b10b2ab341bbcb163d041c44c1a20172ee1.tar.gz
Revert "nodejs: upgrade to 0.10.4"
This reverts commit 903e7131ba5225b085cd612199e88697f2e9e493.
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch60
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.8.18.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_0.10.4.bb)10
2 files changed, 65 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch
new file mode 100644
index 0000000000..6268d6940e
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch
@@ -0,0 +1,60 @@
+From bf701e7cb3616631a354ed9ecbed6dd16f60c60d Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 30 Jan 2013 10:43:47 +0100
+Subject: [PATCH] gcc has a builtin define to denote hard abi when in use, e.g.
+ when using -mfloat-abi=hard it will define __ARM_PCS_VFP to 1 and therefore
+ we should check that to determine which calling convention is in use and not
+ __VFP_FP__ which merely indicates presence of VFP unit
+
+The fix has been provided by Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Forwarded
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ deps/v8/src/arm/assembler-arm.cc | 4 ++--
+ deps/v8/src/platform-linux.cc | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/deps/v8/src/arm/assembler-arm.cc b/deps/v8/src/arm/assembler-arm.cc
+index 1787d15..c64ef58 100644
+--- a/deps/v8/src/arm/assembler-arm.cc
++++ b/deps/v8/src/arm/assembler-arm.cc
+@@ -71,10 +71,10 @@ static unsigned CpuFeaturesImpliedByCompiler() {
+ // If the compiler is allowed to use VFP then we can use VFP too in our code
+ // generation even when generating snapshots. ARMv7 and hardware floating
+ // point support implies VFPv3, see ARM DDI 0406B, page A1-6.
+-#if defined(CAN_USE_ARMV7_INSTRUCTIONS) && defined(__VFP_FP__) \
++#if defined(CAN_USE_ARMV7_INSTRUCTIONS) && defined(__ARM_PCS_VFP) \
+ && !defined(__SOFTFP__)
+ answer |= 1u << VFP3 | 1u << ARMv7 | 1u << VFP2;
+-#endif // defined(CAN_USE_ARMV7_INSTRUCTIONS) && defined(__VFP_FP__)
++#endif // defined(CAN_USE_ARMV7_INSTRUCTIONS) && defined(__ARM_PCS_VFP)
+ // && !defined(__SOFTFP__)
+ #endif // _arm__
+
+diff --git a/deps/v8/src/platform-linux.cc b/deps/v8/src/platform-linux.cc
+index ed9eb79..10d1879 100644
+--- a/deps/v8/src/platform-linux.cc
++++ b/deps/v8/src/platform-linux.cc
+@@ -170,7 +170,7 @@ bool OS::ArmCpuHasFeature(CpuFeature feature) {
+ // calling this will return 1.0 and otherwise 0.0.
+ static void ArmUsingHardFloatHelper() {
+ asm("mov r0, #0":::"r0");
+-#if defined(__VFP_FP__) && !defined(__SOFTFP__)
++#if defined(__ARM_PCS_VFP) && !defined(__SOFTFP__)
+ // Load 0x3ff00000 into r1 using instructions available in both ARM
+ // and Thumb mode.
+ asm("mov r1, #3":::"r1");
+@@ -195,7 +195,7 @@ static void ArmUsingHardFloatHelper() {
+ #else
+ asm("vmov d0, r0, r1");
+ #endif // __thumb__
+-#endif // defined(__VFP_FP__) && !defined(__SOFTFP__)
++#endif // defined(__ARM_PCS_VFP) && !defined(__SOFTFP__)
+ asm("mov r1, #0":::"r1");
+ }
+
+--
+1.8.1
+
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.10.4.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.8.18.bb
index 3d81ccfb3b..ec9e4cf061 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.10.4.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.8.18.bb
@@ -1,15 +1,15 @@
DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
HOMEPAGE = "http://nodejs.org"
-# tools/wrk is under Apache-2.0
-LICENSE = "MIT & BSD & Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1b19aee7bf088151c559f3ec9f830b44"
+LICENSE = "MIT & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=95a589a3257ab7dfe37d8a8379e3c72d"
DEPENDS = "openssl"
SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \
+ file://0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch \
"
-SRC_URI[md5sum] = "a4554450864af89c4420c54349b62295"
-SRC_URI[sha256sum] = "1c960d2822447a9e4f7c46b832ff05e86743033c6643d644975af1cbf6a44fb8"
+SRC_URI[md5sum] = "25ed6aa5710ac46b867ff3f17a4da1d6"
+SRC_URI[sha256sum] = "1d63dd42f9bd22f087585ddf80a881c6acbe1664891b1dda3b71306fe9ae00f9"
S = "${WORKDIR}/node-v${PV}"