aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-11-18 15:40:20 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-11-18 23:20:03 +0100
commitc13c5f40160d289bb62538a16900fed30621cb22 (patch)
tree5b808b50c7e0840fe25b7f729d3ba52d8a803fb9 /meta-oe/recipes-devtools
parent63dda30632b7fcceead0223129c5e3960b1d8667 (diff)
downloadmeta-openembedded-contrib-c13c5f40160d289bb62538a16900fed30621cb22.tar.gz
python-numpy: add native support
The compile hack to use a correct config.h isn't needed for native builds, so mark it as target-specific. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
index e6d328f946..04cb2f183f 100644
--- a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
+++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -40,7 +40,7 @@ inherit distutils
# Make the build fail and replace *config.h with proper one
# This is a ugly, ugly hack - Koen
-do_compile_prepend() {
+do_compile_prepend_class-target() {
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
true
@@ -72,3 +72,7 @@ RDEPENDS_${PN} = "python-unittest \
python-subprocess \
python-compression \
"
+
+RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND = "native nativesdk"