aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-09 22:08:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-11 11:33:38 +0200
commit79b8431f61235f9b00005919d3033a8adef102b0 (patch)
tree2f426955e354000190cfb40bf24c42834ccf42b0 /meta-oe/recipes-devtools
parentae72ce9aebaac49215caab1d41eed0f3e37d46e6 (diff)
downloadmeta-openembedded-contrib-79b8431f61235f9b00005919d3033a8adef102b0.tar.gz
nodejs: remove older 0.6.21
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch22
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb65
2 files changed, 0 insertions, 87 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch b/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch
deleted file mode 100644
index 36e8bf1c97..0000000000
--- a/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix hardfloat detection
-
-gcc has a builtin define to denote hard abi when in use, e.g. when
-using -mfloat-abi=hard it will define __ARM_PCS_VFP to 1 and therefore
-we should check that to determine which calling convention is in use
-and not __VFP_FP__ which merely indicates presence of VFP unit
-
-The fix has been provided by Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Forwarded
-
---- a/deps/v8/src/platform-linux.cc 2012-05-17 12:52:59.329519921 -0700
-+++ b/deps/v8/src/platform-linux.cc 2012-05-17 12:54:02.037521511 -0700
-@@ -212,7 +212,7 @@
- // calling this will return 1.0 and otherwise 0.0.
- static void ArmUsingHardFloatHelper() {
- asm("mov r0, #0");
--#if defined(__VFP_FP__) && !defined(__SOFTFP__)
-+#if defined(__ARM_PCS_VFP) && !defined(__SOFTFP__)
- // Load 0x3ff00000 into r1 using instructions available in both ARM
- // and Thumb mode.
- asm("mov r1, #3");
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb
deleted file mode 100644
index 3d034f2fcc..0000000000
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb
+++ /dev/null
@@ -1,65 +0,0 @@
-DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
-HOMEPAGE = "http://nodejs.org"
-LICENSE = "MIT & BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=914812f2875eef849b5c509cc25dcb4f"
-
-DEPENDS = "openssl"
-
-SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \
- file://fix-hardfloat-detection.patch"
-SRC_URI[md5sum] = "0da985a0bf820400af92363b9f453fe4"
-SRC_URI[sha256sum] = "22265fd07e09c22f1d058156d548e7398c9740210f534e2f848eeab5b9772117"
-
-S = "${WORKDIR}/node-v${PV}"
-
-# v8 errors out if you have set CCACHE
-CCACHE = ""
-
-do_configure_virtclass-native () {
- sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript
- sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript
-
- ./configure --prefix=${prefix} --without-snapshot
-}
-
-# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround waf+scons
-do_configure () {
- echo '#!/bin/sh' > ${WORKDIR}/gcc
- echo '${CC} $@' >> ${WORKDIR}/gcc
-
- echo '#!/bin/sh' > ${WORKDIR}/g++
- echo '${CXX} $@'>> ${WORKDIR}/g++
-
- chmod +x ${WORKDIR}/gcc ${WORKDIR}/g++
-
- sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript
- sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript
-
- export PATH=${WORKDIR}:${PATH}
- export CC=gcc
- export CXX=g++
-
- ./configure --prefix=${prefix} --without-snapshot
-}
-
-do_compile_virtclass-native () {
- make BUILDTYPE=Release
-}
-
-do_compile () {
- export PATH=${WORKDIR}:${PATH}
- export CC=gcc
- export CXX=g++
- make BUILDTYPE=Release
-}
-
-do_install () {
- export DESTDIR=${D}
- oe_runmake install
-}
-
-RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
-RDEPENDS_${PN}_virtclass-native = "curl-native python-native"
-
-FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules"
-BBCLASSEXTEND = "native"