aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-11-01 17:22:38 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-11-18 23:11:35 +0100
commit6c2a235545839b1ae6e9940cafe2b6617a57a344 (patch)
treea3b6afdbc399d56cd157bda0d621f6464d709428 /meta-oe/recipes-devtools
parentbab1d28a3520556f1fd0ecd70ea9579e25dbcb3e (diff)
downloadmeta-openembedded-contrib-6c2a235545839b1ae6e9940cafe2b6617a57a344.tar.gz
python-mako: use BBCLASSEXTEND instead of native recipe
There isn't a need for a separate native recipe, so use BBCLASSEXTEND and overrides. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python-mako-native_0.7.2.bb5
-rw-r--r--meta-oe/recipes-devtools/python/python-mako_0.7.2.bb3
2 files changed, 3 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/python/python-mako-native_0.7.2.bb b/meta-oe/recipes-devtools/python/python-mako-native_0.7.2.bb
deleted file mode 100644
index 05479db454..0000000000
--- a/meta-oe/recipes-devtools/python/python-mako-native_0.7.2.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require python-mako_${PV}.bb
-inherit native pythonnative
-
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb b/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
index 9e381f3dc2..1d2bdd7f94 100644
--- a/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
+++ b/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
@@ -17,3 +17,6 @@ RDEPENDS_${PN} = "python-threading \
python-netclient \
python-html \
"
+RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND = "native nativesdk"