aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-04-12 10:04:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:16:52 +0200
commit5ce31df17f12bb4507eae2b383f5462952dfa7b5 (patch)
treeb5c84187accac87adb64a31a072458beb9e90589 /meta-oe/recipes-devtools
parent4fe1acbe3b9ce058264e1a9e43d179a62ab5daa2 (diff)
downloadmeta-openembedded-contrib-5ce31df17f12bb4507eae2b383f5462952dfa7b5.tar.gz
cloud9: use node4 to build o3-xml binary
Using node 0.8.x will make it crash at runtime Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
index a78c653c71..0c07b128bb 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
PR = "r2"
-DEPENDS = "libxml2 nodejs-native"
+# Nodejs-native for node-waf, nodejs4-native for the headers
+DEPENDS = "libxml2 nodejs-native nodejs4-native"
SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \
@@ -68,11 +69,11 @@ do_configure () {
node-waf -vv configure
}
-EXTRA_CXXFLAGS = "-Idefault/include -I../include -Idefault/hosts -I../hosts -Idefault/modules -I../modules -Idefault/deps -I../deps -I${STAGING_DIR_NATIVE}/usr/include/node -fPIC -DPIC"
+EXTRA_CXXFLAGS = "-Idefault/include -I../include -Idefault/hosts -I../hosts -Idefault/modules -I../modules -Idefault/deps -I../deps -I${STAGING_DIR_NATIVE}/usr/include/node4 -fPIC -DPIC"
do_compile () {
cd ${WORKDIR}/o3
- node tools/gluegen.js
+ node4 tools/gluegen.js
cd hosts
${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node.o node-o3/sh_node.cc
${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node_libs.o node-o3/sh_node_libs.cc