aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-04-12 10:04:45 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:16:52 +0200
commit4fe1acbe3b9ce058264e1a9e43d179a62ab5daa2 (patch)
tree3b964a017c26702078f5e1dc5dd954baa1caf477 /meta-oe/recipes-devtools
parent3628f272d14b8266c87b5abce0fb80ff739aeced (diff)
downloadmeta-openembedded-contrib-4fe1acbe3b9ce058264e1a9e43d179a62ab5daa2.tar.gz
nodejs4: reinstate installing all the files
Cloud9 needs the headers to build the o3-xml binary, using 0.8.x headers makes it crash. This installs everything namespaced as 'node4' to avoid collisions. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb18
1 files changed, 15 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb b/meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb
index 522b5396a7..58ca135273 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb
@@ -28,8 +28,20 @@ do_compile () {
}
do_install () {
- install -d ${D}${bindir}
- install -m 0755 build/default/node ${D}${bindir}/node4
-}
+ DESTDIR=${D} oe_runmake install
+
+ # fix namespace conflicts with other nodejs recipes
+ mv ${D}${bindir}/node ${D}${bindir}/node4
+ mv ${D}${bindir}/node-waf ${D}${bindir}/node4-waf
+
+ mv ${D}${includedir}/node ${D}${includedir}/node4
+ mv ${D}${libdir}/node ${D}${libdir}/node4
+ mv ${D}${libdir}/pkgconfig/nodejs.pc ${D}${libdir}/pkgconfig/nodejs4.pc
+ sed -i -e s:include/node:include/node4: ${D}${libdir}/pkgconfig/nodejs4.pc
+
+ mv ${D}${datadir}/man/man1/node.1 ${D}${datadir}/man/man1/node4.1
+}
+FILES_${PN} += "${libdir}/node4/wafadmin"
+BBCLASSEXTEND = "native"