aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2017-07-28 15:40:56 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:19:41 +0200
commite406d4f5ae8c3ad735611c2f1a4a8df1c9e1db6d (patch)
tree5f4c86844562eb5b46b51770de71eaae60a6866b /meta-oe/recipes-devtools
parent4b923a2c353d4f96fd8bf2c2c0c43cf3cfc0f257 (diff)
downloadmeta-openembedded-contrib-e406d4f5ae8c3ad735611c2f1a4a8df1c9e1db6d.tar.gz
android-tools: fix issue with missing files in eSDK updates
If this recipe was included in an eSDK and then eSDK incremental updates were generated by repeatedly running the oe-publish-sdk script, after installing the first of such updates, and any following as well, with 'devtool sdk-updates' the eSDK gets corrupted. Indeed some of the files listed in SRC_URI (namely anything in *.patch and *.service) get deleted by those updates, with bitbake that starts warning with 'Unable to get checksum for android-tools* SRC_URI entry' at every parse. Since the files are missing, such warnings turn into errors if trying to bake android-tools. The root cause is the somewhat unusual presence of android-tools/.gitignore, indeed ignore everything not explicitly excepted. When oe-publish-sdk creates the git repo it relies on to feed eSDK updates, the .gitignore gets honored, leading to the buggy behaviour above. This patch adds *.patch and *.service to the excepted patterns in .gitignore Note that, although this solves the issue, it does not prevent from it popping up again if new files get added to android-tools/ without explicitly excluding them from .gitignore. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/.gitignore2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/.gitignore b/meta-oe/recipes-devtools/android-tools/android-tools/.gitignore
index b8a08f8248..b034c10a1e 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/.gitignore
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/.gitignore
@@ -3,6 +3,8 @@
!*.indirectionsymlink
!*.[ch]
!*.mk
+!*.patch
+!*.service
!NOTICE
!MODULE_LICENSE_*
!/system/