aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-05-04 15:50:37 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-23 15:49:34 +0200
commita978ea30514307b565512817ff47d8d25cb10ff7 (patch)
treeae6bbe760906615462d35ae1dcdc791b49f761d2 /meta-oe/recipes-devtools
parentfcf4ca384c94e61ef458f14ab1192f6de2b7ee73 (diff)
downloadmeta-openembedded-contrib-a978ea30514307b565512817ff47d8d25cb10ff7.tar.gz
openocd: Add recipe for openocd
Adds a recipe for openocd. Based on recipe found in meta-zephyr. Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
new file mode 100644
index 0000000000..783a6c707f
--- /dev/null
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "libusb-compat libftdi"
+RDEPENDS_${PN} = "libusb1"
+
+SRC_URI = "git://repo.or.cz/openocd.git \
+ "
+SRCREV = "cb317eabf2d162365467aeb89b564828e5e6d6f3"
+
+PV = "0.10+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools-brokensep gettext
+
+BBCLASSEXTEND += "nativesdk"
+
+EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html "
+
+do_configure() {
+ ./bootstrap
+ oe_runconf ${EXTRA_OECONF}
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+ if [ -e "${D}${infodir}" ]; then
+ rm -Rf ${D}${infodir}
+ fi
+ if [ -e "${D}${mandir}" ]; then
+ rm -Rf ${D}${mandir}
+ fi
+ if [ -e "${D}${bindir}/.debug" ]; then
+ rm -Rf ${D}${bindir}/.debug
+ fi
+}
+
+FILES_${PN} = " \
+ ${datadir}/openocd/* \
+ ${bindir}/openocd \
+ "
+
+PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
+PACKAGECONFIG ??= "sysfsgpio"