aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-08-13 09:16:13 +0000
committerKhem Raj <raj.khem@gmail.com>2018-08-15 08:20:06 -0700
commit29a51db18a729bcd9b0379eab27ff5e9e863dc79 (patch)
tree9361985848a218c15fb26b05745fefb0c4cc4ef5 /meta-oe/recipes-devtools
parentf0acce20d44b78e1679060419e280b12c217b01d (diff)
downloadmeta-openembedded-contrib-29a51db18a729bcd9b0379eab27ff5e9e863dc79.tar.gz
openocd: prevent fetching git submodules during do_configure
* I've tried just disabling them with: --disable-internal-jimtcl --disable-internal-libjaylink but that still tries to use missing jim.h: | ./src/helper/jim-nvp.h:47:10: fatal error: jim.h: No such file or directory | #include <jim.h> | ^~~~~~~ | compilation terminated. | Makefile:3619: recipe for target 'src/libopenocd_la-openocd.lo' failed | make[2]: *** [src/libopenocd_la-openocd.lo] Error 1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb21
1 files changed, 15 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
index 84727bf970..21a86de390 100644
--- a/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -4,10 +4,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "libusb-compat libftdi"
RDEPENDS_${PN} = "libusb1"
-SRC_URI = "git://repo.or.cz/openocd.git \
- file://0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch \
- "
-SRCREV = "cdf1e826eb23c29de1019ce64125f644f01b0afe"
+SRC_URI = " \
+ git://repo.or.cz/openocd.git;protocol=http;name=openocd \
+ git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
+ git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
+ git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
+ file://0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch \
+"
+
+SRCREV_FORMAT = "openocd"
+SRCREV_openocd = "cdf1e826eb23c29de1019ce64125f644f01b0afe"
+SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
+SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
+SRCREV_libjaylink = "8645845c1abebd004e991ba9a7f808f4fd0c608b"
PV = "0.10+gitr${SRCPV}"
S = "${WORKDIR}/git"
@@ -16,10 +25,10 @@ inherit pkgconfig autotools-brokensep gettext
BBCLASSEXTEND += "nativesdk"
-EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html "
+EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
do_configure() {
- ./bootstrap
+ ./bootstrap nosubmodule
oe_runconf ${EXTRA_OECONF}
}