aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.54.02.bb
diff options
context:
space:
mode:
authorArthur She <arthur.she@linaro.org>2020-08-16 23:16:08 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-17 12:26:41 -0700
commit608b0ee23458fd8a538b8b2177b1a4339e4422fb (patch)
tree0fc618d155982e68b7eeefcdb853c08f00a4af2b /meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.54.02.bb
parentc699d2088e4149dc3043542652b6370c51735b6d (diff)
downloadmeta-openembedded-contrib-608b0ee23458fd8a538b8b2177b1a4339e4422fb.tar.gz
xmlrpc-c: Upgrade 1.51.03 -> 1.54.02
Upgrade to release 1.54.02: - Build: Use 'curl-config' found at configure time, not at make time. - Fix bug: 'toValue' won't compile for vector of vectors or map of vectors. Thanks Yang Bo . - Fix tiny memory leak in virtually impossible low memory situation. It also solved one igt-gpu-tools test results misleading issue [1] [1] https://gitlab.freedesktop.org/drm/igt-gpu-tools/-/issues/92 Signed-off-by: Arthur She <arthur.she@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.54.02.bb')
-rw-r--r--meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.54.02.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.54.02.bb b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.54.02.bb
new file mode 100644
index 0000000000..c1f0b78cae
--- /dev/null
+++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.54.02.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \
+write an XML-RPC server or client in C or C++."
+
+HOMEPAGE = "http://xmlrpc-c.sourceforge.net/"
+LICENSE = "BSD & MIT"
+LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951"
+
+SRC_URI = "git://github.com/mirror/xmlrpc-c.git \
+ file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \
+ file://0002-fix-formatting-issues.patch \
+ "
+
+#Release 1.54.02
+SRCREV = "86405c7e1bd4f70287204a28d242a1054daab520"
+
+S = "${WORKDIR}/git/stable"
+
+DEPENDS = "libxml2"
+
+inherit autotools-brokensep binconfig pkgconfig
+
+TARGET_CFLAGS += "-Wno-narrowing"
+
+EXTRA_OEMAKE += "CC_FOR_BUILD='${BUILD_CC}' \
+ LD_FOR_BUILD='${BUILD_LD}' \
+ CFLAGS_FOR_BUILD='${BUILD_CFLAGS}' \
+ LDFLAGS_FOR_BUILD='${BUILD_LDFLAGS}' \
+ "
+
+EXTRA_OECONF += "--disable-libwww-client --disable-wininet-client"
+
+PACKAGECONFIG ??= "curl cplusplus"
+
+PACKAGECONFIG[abyss] = "--enable-abyss-server --enable-abyss-threads --enable-abyss-openssl,--disable-abyss-server --disable-abyss-threads --disable-abyss-openssl,openssl,"
+PACKAGECONFIG[cplusplus] = "--enable-cplusplus,--disable-cplusplus,,"
+PACKAGECONFIG[curl] = "--enable-curl-client,--disable-curl-client,curl,curl"
+
+do_configure() {
+ install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
+ install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
+ autoconf
+ oe_runconf
+ # license is incompatible with lib/util/getoptx.*
+ rm -fv ${S}/tools/turbocharger/mod_gzip.c
+}
+
+BBCLASSEXTEND = "native"
+
+CLEANBROKEN = "1"