aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-12-31 15:15:26 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-08 12:04:26 +0100
commitad6e0184266241e28216681f6fa0b7dc48f79344 (patch)
tree3e1eed6fd58a6e5a1dc61ba3b28a50f60d6f2a28 /meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb
parent2b30fc6fe906d525b703e999138fcb9a0da150db (diff)
downloadmeta-openembedded-contrib-ad6e0184266241e28216681f6fa0b7dc48f79344.tar.gz
libc-client: rename to uw-imap, upgrade to 2007f
* Upgrade to 2007f * Rename to uw-imap; this is the name used by Fedora and is much more sensible than libc-client * Fix errors when linking the library against code compiled with -fPIC such as mod-php (patch from Fedora). * Add a security patch from Fedora * Rename files directory to uw-imap Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb')
-rw-r--r--meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb b/meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb
new file mode 100644
index 0000000000..e1a987710d
--- /dev/null
+++ b/meta-oe/recipes-devtools/uw-imap/uw-imap_2007f.bb
@@ -0,0 +1,41 @@
+SUMMARY = "UW c-client library for mail protocols"
+SECTION = "devel"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a6a4ddbb7cd2999f6827ee143f6fcd97"
+
+DEPENDS = "openssl libpam"
+
+SRC_URI = "ftp://ftp.cac.washington.edu/imap/imap-${PV}.tar.gz \
+ file://quote_cctype.patch \
+ file://imap-2007e-shared.patch \
+ file://imap-2007f-format-security.patch \
+ "
+
+SRC_URI[md5sum] = "2126fd125ea26b73b20f01fcd5940369"
+SRC_URI[sha256sum] = "53e15a2b5c1bc80161d42e9f69792a3fa18332b7b771910131004eb520004a28"
+
+S = "${WORKDIR}/imap-${PV}"
+
+EXTRA_OEMAKE = "CC='${CC}'"
+
+HEADERS = "src/c-client/*.h src/osdep/unix/*.h c-client/auths.c c-client/linkage.c c-client/linkage.h c-client/osdep.h"
+
+do_compile() {
+ echo "SSLINCLUDE=${STAGING_INCDIR} SSLLIB=${STAGING_LIBDIR}" > ${S}/SPECIALS
+ oe_runmake lnp
+}
+
+do_install() {
+ install -d ${D}${includedir}/c-client
+ install ${HEADERS} ${D}${includedir}/c-client
+ install -d ${D}${libdir}
+ install c-client/c-client.a ${D}${libdir}/libc-client.a
+}
+
+RPROVIDES_${PN} = "libc-client"
+RREPLACES_${PN} = "libc-client"
+RCONFLICTS_${PN} = "libc-client"
+
+ALLOW_EMPTY_${PN} = "1"
+