aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-06-13 10:43:43 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-20 12:30:07 +0200
commita695d15ea384001a7e68c20972e9b21785d57275 (patch)
tree2d51553b9d820678032f3d06ba691515db564368 /meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb
parenteccb3d022a063d74727690c8e4f384b8406b13a6 (diff)
downloadmeta-openembedded-contrib-a695d15ea384001a7e68c20972e9b21785d57275.tar.gz
tk: Upgrade to 8.6.0
This also fixes the build since tcl is moved to 8.6.0 in OE-Core The licence has been updated a little license.terms 2009-11-13 10:38:48.000000000 -0800 license.terms 2012-12-19 07:39:12.000000000 -0800 @@ -1,7 +1,8 @@ This software is copyrighted by the Regents of the University of -California, Sun Microsystems, Inc., and other parties. The following -terms apply to all files associated with the software unless explicitly -disclaimed in individual files. +California, Sun Microsystems, Inc., Scriptics Corporation, ActiveState +Corporation, Apple Inc. and other parties. The following terms apply to +all files associated with the software unless explicitly disclaimed in +individual files. The authors hereby grant permission to use, copy, modify, distribute, and license this software and its documentation for any purpose, provided @@ -28,12 +29,12 @@ GOVERNMENT USE: If you are acquiring this software on behalf of the U.S. government, the Government shall have only "Restricted Rights" -in the software and related documentation as defined in the Federal +in the software and related documentation as defined in the Federal Acquisition Regulations (FARs) in Clause 52.227.19 (c) (2). If you are acquiring the software on behalf of the Department of Defense, the software shall be classified as "Commercial Computer Software" and the Government shall have only "Restricted Rights" as defined in Clause -252.227-7013 (c) (1) of DFARs. Notwithstanding the foregoing, the +252.227-7013 (b) (3) of DFARs. Notwithstanding the foregoing, the authors grant the U.S. Government and others acting in its behalf permission to use and distribute the software in accordance with the terms specified in this license. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb')
-rw-r--r--meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb b/meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb
new file mode 100644
index 0000000000..b76f58f9ea
--- /dev/null
+++ b/meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Tool Command Language ToolKit Extension"
+HOMEPAGE = "http://tcl.sourceforge.net"
+SECTION = "devel/tcltk"
+LICENSE = "tcl"
+LIC_FILES_CHKSUM = "file://license.terms;md5=c88f99decec11afa967ad33d314f87fe"
+DEPENDS = "tcl virtual/libx11 libxt"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/tcl/tk${PV}-src.tar.gz \
+ file://confsearch.diff;striplevel=2 \
+ file://non-linux.diff;striplevel=2 \
+ file://tklibrary.diff;striplevel=2 \
+ file://tkprivate.diff;striplevel=2 \
+ file://fix-xft.diff \
+"
+SRC_URI[md5sum] = "b883a1a3c489c17413fb602a94bf54e8"
+SRC_URI[sha256sum] = "5c708b2b6f658916df59190b27750fa1ea2bc10992108e10f961c0700f058de6"
+
+S = "${WORKDIR}/tk${PV}/unix"
+LDFLAGS += "-Wl,-rpath,${libdir}/tcltk/8.6.0/lib"
+inherit autotools
+
+EXTRA_OECONF = "\
+ --enable-threads \
+ --with-x \
+ --with-tcl=${STAGING_BINDIR_CROSS} \
+"
+
+do_install_append() {
+ mv libtk8.6.so libtk8.6.so.0
+ oe_libinstall -so libtk8.6 ${D}${libdir}
+ ln -sf wish8.6 ${D}${bindir}/wish
+}
+
+PACKAGES =+ "${PN}-lib"
+
+FILES_${PN}-lib = "${libdir}/libtk8.6.so.*"
+FILES_${PN} += "${libdir}/tk*"
+
+BINCONFIG_GLOB = "*Config.sh"
+BBCLASSEXTEND = "native"