aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/sip
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-devtools/sip
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/sip')
-rw-r--r--meta-oe/recipes-devtools/sip/sip3_4.19.23.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb b/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
index ae8df5055a..792cdb5378 100644
--- a/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
+++ b/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
@@ -20,9 +20,9 @@ PACKAGES += "python3-sip3"
BBCLASSEXTEND = "native"
CONFIGURE_SYSROOT = "${STAGING_DIR_HOST}"
-CONFIGURE_SYSROOT_class-native = "${STAGING_DIR_NATIVE}"
+CONFIGURE_SYSROOT:class-native = "${STAGING_DIR_NATIVE}"
-do_configure_prepend() {
+do_configure:prepend() {
echo "py_platform = linux" > sip.cfg
echo "py_inc_dir = ${STAGING_INCDIR}/python%(py_major).%(py_minor)${PYTHON_ABI}" >> sip.cfg
echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg
@@ -36,5 +36,5 @@ do_install() {
oe_runmake install
}
-FILES_python3-sip3 = "${libdir}/${PYTHON_DIR}/site-packages/"
-FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
+FILES:python3-sip3 = "${libdir}/${PYTHON_DIR}/site-packages/"
+FILES:${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"