aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-06-11 21:35:37 -0400
committerKhem Raj <raj.khem@gmail.com>2020-06-11 22:01:14 -0700
commit224b39eea2e799588d54b71fabefde70d9ba185f (patch)
treed220664a341c26f4d4444152acd9cb8b683ffce8 /meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
parent86a61ab431e6b77da1068b98619cd8be717a8a40 (diff)
downloadmeta-openembedded-contrib-224b39eea2e799588d54b71fabefde70d9ba185f.tar.gz
serialcheck: switch to a fork and update to the latest
Original serialcheck at https://git.breakpoint.cc/cgit/bigeasy/serialcheck.git/ hasn't been updated since early 2015 and has been forked and continued at https://github.com/nsekhar/serialcheck Switch to the fork and update to the latest, while dropping merged and unneeded patches. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb')
-rw-r--r--meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb27
1 files changed, 14 insertions, 13 deletions
diff --git a/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb b/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
index cd5e0a4e5c..16eaf62f78 100644
--- a/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
+++ b/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
@@ -1,30 +1,31 @@
SUMMARY = "Application to verify operation of serial ports"
-HOMEPAGE = "http://git.breakpoint.cc/cgit/bigeasy/serialcheck.git/"
+HOMEPAGE = "https://github.com/nsekhar/serialcheck"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRC_URI = "git://git.breakpoint.cc/bigeasy/serialcheck.git \
- file://0001-Add-option-to-enable-internal-loopback.patch \
- file://0002-Restore-original-loopback-config.patch \
- file://0001-Makefile-Change-order-of-link-flags.patch \
- "
+SRC_URI = " \
+ git://github.com/nsekhar/serialcheck.git \
+"
-SRCREV = "63854a2d0c0129efab132ec328a75279e013fb84"
+SRCREV = "45eb2ffa5378396e85432872833890b0a1cba872"
S = "${WORKDIR}/git"
+inherit autotools
+
DEPENDS_append_libc-musl = " argp-standalone"
-EXTRA_OEMAKE = "-e MAKEFLAGS="
+EXTRA_OEMAKE_append_libc-musl = " LIBS='-largp'"
-CFLAGS_prepend = "-Wall -Wextra -Wno-sign-compare -Wno-pointer-sign "
-LDFLAGS_append_libc-musl = " -largp"
+PACKAGE_BEFORE_PN += "${PN}-stats"
do_install() {
install -d ${D}${bindir}
- install ${S}/serialcheck ${D}${bindir}
+ install ${B}/serialcheck ${D}${bindir}
+ install ${B}/serialstats ${D}${bindir}
install -d ${D}${docdir}/${BP}
- install ${S}/Readme.txt ${D}${docdir}/${BP}
+ install ${S}/README ${D}${docdir}/${BP}
}
-CLEANBROKEN = "1"
+
+FILES_${PN}-stats = "${bindir}/serialstats"
BBCLASSEXTEND = "nativesdk"