aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@microsoft.com>2019-08-05 12:03:08 +0100
committerKhem Raj <raj.khem@gmail.com>2019-08-05 17:55:36 -0700
commitf8e1d0c17658d1b41d201c63b285d10d9aa8cfc6 (patch)
tree6306055e3ef8dabe65da303086fda78d7a6cbfb7 /meta-oe/recipes-devtools/python
parent85feefecac549b4ddaae9727ec98a9fd9f0b457c (diff)
downloadmeta-openembedded-contrib-f8e1d0c17658d1b41d201c63b285d10d9aa8cfc6.tar.gz
python-pygobject: move python-setuptools from RDEPENDS to DEPENDS
python-setuptools is necessary to build pygobject but not to run it, as also documented by the upstream packaging guide: https://gitlab.gnome.org/GNOME/pygobject/blob/master/docs/packagingguide.rst Move it to DEPENDS to shrink the runtime dependency chain, as setuptools includes scripts to download other packages, which might not be desired on a minimal image. Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-pygobject_3.32.2.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.32.2.bb b/meta-oe/recipes-devtools/python/python-pygobject_3.32.2.bb
index 4d26a78aeb..9c175e682d 100644
--- a/meta-oe/recipes-devtools/python/python-pygobject_3.32.2.bb
+++ b/meta-oe/recipes-devtools/python/python-pygobject_3.32.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
GNOMEBASEBUILDCLASS = "meson"
inherit gnomebase gobject-introspection distutils-base upstream-version-is-even
-DEPENDS += "python glib-2.0"
+DEPENDS += "python python-setuptools glib-2.0"
SRCNAME = "pygobject"
SRC_URI = " \
@@ -30,7 +30,6 @@ PACKAGECONFIG[python] = "-Dpython=python3, -Dpython=python2, , "
PACKAGECONFIG[stagedir] = "-Dstagedir=${PYTHON_SITEPACKAGES_DIR}, -Dstagedir="", , "
BBCLASSEXTEND = "native"
-RDEPENDS_${PN} = "python-setuptools"
RDEPENDS_${PN}_class-native = ""
do_install_append() {