aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-19 16:33:15 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit505774658338002a92c2e32c4c57c55f36c5e36e (patch)
treec5d1032aac37af7493141cdfa56da5b371ce5a59 /meta-oe/recipes-devtools/python
parent66454b26ff49c6cca3dd8d32832078cfa05cd5ef (diff)
downloadmeta-openembedded-contrib-505774658338002a92c2e32c4c57c55f36c5e36e.tar.gz
meta-oe: Remove using python2
This change makes the parsing go though, we still might have build issues, which will be reported in world builds seprately Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-cpuset_1.6.bb18
-rw-r--r--meta-oe/recipes-devtools/python/python-distutils-extra.bb7
-rw-r--r--meta-oe/recipes-devtools/python/python-futures_3.3.0.bb13
-rw-r--r--meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb11
-rw-r--r--meta-oe/recipes-devtools/python/python-pytoml.inc12
-rw-r--r--meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb2
-rw-r--r--meta-oe/recipes-devtools/python/python-six_1.13.0.bb2
-rw-r--r--meta-oe/recipes-devtools/python/python-which_1.1.0.bb19
-rw-r--r--meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch (renamed from meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch)0
-rw-r--r--meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb (renamed from meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb)11
10 files changed, 5 insertions, 90 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb b/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb
deleted file mode 100644
index 1255a51f75..0000000000
--- a/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier"
-SECTION = "devel/python"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-
-S = "${WORKDIR}/git"
-SRCREV = "6c46d71a1c6ee711063153b9f7787280128f7252"
-SRC_URI = "git://github.com/lpechacek/cpuset.git;protocol=https;"
-
-inherit distutils
-
-RDEPENDS_${PN} = "\
- python-core \
- python-re \
- python-logging \
- python-textutils \
- python-unixadmin \
- "
diff --git a/meta-oe/recipes-devtools/python/python-distutils-extra.bb b/meta-oe/recipes-devtools/python/python-distutils-extra.bb
deleted file mode 100644
index eb84f74365..0000000000
--- a/meta-oe/recipes-devtools/python/python-distutils-extra.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require python-distutils-extra.inc
-
-inherit setuptools
-
-RDEPENDS_${PN} = "\
- python-distutils \
-"
diff --git a/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb b/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb
deleted file mode 100644
index 1636f7371d..0000000000
--- a/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables."
-SECTION = "devel/python"
-LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=834d982f973c48b6d662b5944c5ab567"
-HOMEPAGE = "https://github.com/agronholm/pythonfutures"
-DEPENDS = "python"
-
-SRC_URI[md5sum] = "b43a39ae1475e3fd6940f2b4f7214675"
-SRC_URI[sha256sum] = "7e033af76a5e35f58e56da7a91e687706faf4e7bdfb2cbc3f2cca6b9bcda9794"
-
-inherit pypi setuptools
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb b/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb
deleted file mode 100644
index d00d1e2a08..0000000000
--- a/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-DESCRIPTION = "JavaScript minifier."
-HOMEPAGE = "https://github.com/tikitu/jsmin/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a3301ce2ad647e172f4a1016c67324d"
-
-inherit setuptools pypi
-SRC_URI[md5sum] = "00e7a3179a4591aab2ee707b3214e2fd"
-SRC_URI[sha256sum] = "b6df99b2cd1c75d9d342e4335b535789b8da9107ec748212706ef7bbe5c2553b"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-devtools/python/python-pytoml.inc b/meta-oe/recipes-devtools/python/python-pytoml.inc
deleted file mode 100644
index 180531d750..0000000000
--- a/meta-oe/recipes-devtools/python/python-pytoml.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-SUMMARY = "A TOML-0.4.0 parser/writer for Python"
-HOMEPAGE = "https://pypi.python.org/pypi/pytoml/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=cfff423699bdaef24331933ac4f56078"
-
-SRC_URI[md5sum] = "e59dd36a559dd2a876e4c149c69e947b"
-SRC_URI[sha256sum] = "8eecf7c8d0adcff3b375b09fe403407aa9b645c499e5ab8cac670ac4a35f61e7"
-
-inherit pypi
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb b/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb
deleted file mode 100644
index 88fa95317f..0000000000
--- a/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools
-require python-pytoml.inc
diff --git a/meta-oe/recipes-devtools/python/python-six_1.13.0.bb b/meta-oe/recipes-devtools/python/python-six_1.13.0.bb
deleted file mode 100644
index af26e83d60..0000000000
--- a/meta-oe/recipes-devtools/python/python-six_1.13.0.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools
-require recipes-devtools/python/python-six.inc
diff --git a/meta-oe/recipes-devtools/python/python-which_1.1.0.bb b/meta-oe/recipes-devtools/python/python-which_1.1.0.bb
deleted file mode 100644
index 901fdc7637..0000000000
--- a/meta-oe/recipes-devtools/python/python-which_1.1.0.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "which.py -- a portable GNU which replacement"
-HOMEPAGE = "http://code.google.com/p/which/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=030b09798681482b9ad12ac47be496ea"
-
-inherit setuptools pypi python-dir
-
-SRCREV = "425bdeeb2d87c36e2313dc4b8d69ff2bb5a02ee9"
-PYPI_SRC_URI = "git://github.com/trentm/which"
-
-S = "${WORKDIR}/git"
-
-do_install_append() {
- rmdir -p --ignore-fail-on-non-empty ${D}${STAGING_BINDIR_NATIVE}
- rmdir -p --ignore-fail-on-non-empty ${D}${datadir}
-}
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch b/meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch
index 848cda5aad..848cda5aad 100644
--- a/meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch
+++ b/meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb b/meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb
index 0cbd07f666..b016df7198 100644
--- a/meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb
+++ b/meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb
@@ -5,14 +5,13 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
GNOMEBASEBUILDCLASS = "meson"
-inherit gnomebase gobject-introspection distutils-base upstream-version-is-even
+inherit gnomebase gobject-introspection distutils3-base upstream-version-is-even
-DEPENDS += "python glib-2.0"
+DEPENDS += "python3 glib-2.0"
SRCNAME = "pygobject"
SRC_URI = " \
http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
- file://0001-python-pyobject-fix-install-dir.patch \
"
SRC_URI[md5sum] = "ca1dc4f31c1d6d283758e8f315a88ab6"
@@ -22,12 +21,12 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
UNKNOWN_CONFIGURE_WHITELIST = "introspection"
-PACKAGECONFIG ??= "stagedir"
+PACKAGECONFIG ??= ""
PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python-pycairo, python-pycairo"
PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , "
-PACKAGECONFIG[python] = "-Dpython=python3, -Dpython=python2, , "
-PACKAGECONFIG[stagedir] = "-Dstagedir=${PYTHON_SITEPACKAGES_DIR}, -Dstagedir="", , "
+
+EXTRA_OEMESON_append = " -Dpython=python3"
BBCLASSEXTEND = "native"
RDEPENDS_${PN} = "python-pkgutil"