aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-06-25 08:06:41 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-29 10:59:41 +0200
commitb813911696254dfe8f22f217904ee4d85c315da1 (patch)
treedf9a34b5daa5dde5228908d01e94f1ff3b4fa2f6 /meta-oe/recipes-devtools/python
parentecf41acf0dacf2068e9eab0b58f8f9ed8bda5805 (diff)
downloadmeta-openembedded-contrib-b813911696254dfe8f22f217904ee4d85c315da1.tar.gz
cpuset: add new python package
Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-cpuset_1.5.7.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cpuset_1.5.7.bb b/meta-oe/recipes-devtools/python/python-cpuset_1.5.7.bb
new file mode 100644
index 0000000000..8f6532c531
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-cpuset_1.5.7.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+SRCNAME = "cpuset"
+
+SRC_URI = "https://github.com/lpechacek/${SRCNAME}/archive/v${PV}.tar.gz"
+
+SRC_URI[md5sum] = "6ad79b26ba03f559604d74513cc34392"
+SRC_URI[sha256sum] = "32334e164415ed5aec83c5ffc3dc01c418406eb02d96d881fdfd495587ff0c01"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} = "\
+ python-core \
+ python-re \
+ python-logging \
+ python-textutils \
+ python-unixadmin \
+ "