aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-12-15 10:28:45 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-04 14:53:59 +0100
commit524f332a5db28e489737a6fff1154755cfdb0743 (patch)
treecc0045948c196ed2c217f7441ea4e16c6bbf245c /meta-oe/recipes-devtools/python
parent50bd6e1a9e141c294d9468a68b5067633371879a (diff)
downloadmeta-openembedded-contrib-524f332a5db28e489737a6fff1154755cfdb0743.tar.gz
python-tornado: move old version recipe from meta-oe to meta-python
Move old version recipe of python-tornado from meta-oe to meta-python that there is a higher version in meta-python already. And rename from _git to exact version _2.2.1. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch32
-rw-r--r--meta-oe/recipes-devtools/python/python-tornado_git.bb16
2 files changed, 0 insertions, 48 deletions
diff --git a/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch b/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch
deleted file mode 100644
index 0b0d471a42..0000000000
--- a/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From d7fb0a6ef3f3cbdfc1f21f5a67d54fa9d2c1e183 Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Wed, 2 Nov 2011 11:07:24 +0100
-Subject: [PATCH] disable AI_ADDRCONFIG flag
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-
-Upstream-Status: unknown
----
- tornado/netutil.py | 6 ------
- 1 files changed, 0 insertions(+), 6 deletions(-)
-
-diff --git a/tornado/netutil.py b/tornado/netutil.py
-index cfff0ba..c181f24 100644
---- a/tornado/netutil.py
-+++ b/tornado/netutil.py
-@@ -238,12 +238,6 @@ def bind_sockets(port, address=None, family=socket.AF_UNSPEC, backlog=128):
- if address == "":
- address = None
- flags = socket.AI_PASSIVE
-- if hasattr(socket, "AI_ADDRCONFIG"):
-- # AI_ADDRCONFIG ensures that we only try to bind on ipv6
-- # if the system is configured for it, but the flag doesn't
-- # exist on some platforms (specifically WinXP, although
-- # newer versions of windows have it)
-- flags |= socket.AI_ADDRCONFIG
- for res in set(socket.getaddrinfo(address, port, family, socket.SOCK_STREAM,
- 0, flags):
- af, socktype, proto, canonname, sockaddr = res
---
-1.7.2.5
-
diff --git a/meta-oe/recipes-devtools/python/python-tornado_git.bb b/meta-oe/recipes-devtools/python/python-tornado_git.bb
deleted file mode 100644
index 28026b352b..0000000000
--- a/meta-oe/recipes-devtools/python/python-tornado_git.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://README;md5=e7fb9954003d7cd93322ccf282210d1c"
-
-PV = "2.2.1+git${SRCPV}"
-
-SRCREV = "c501917eba46dec30b1f2ef12497dffc4beec505"
-SRC_URI = "git://github.com/facebook/tornado.git;branch=branch2.2 \
- file://0001-disable-AI_ADDRCONFIG-flag.patch \
-"
-
-S = "${WORKDIR}/git"
-
-inherit setuptools
-
-