aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-24 09:34:07 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-26 20:10:07 -0700
commite4031bcc78ba92f661b257442a0fa13c5dc4b912 (patch)
tree091dfb148aece348f5a0a726fe9f4300c6e23987 /meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
parent95a8804cad0caed852a5bcf58475a99f1907f06f (diff)
downloadmeta-openembedded-contrib-e4031bcc78ba92f661b257442a0fa13c5dc4b912.tar.gz
protobuf-c: fix build error with protobuf 3.6.0.1
1. protoc-c depend on protobuf, from protobuf 3.6.0.1, scoped_array is removed, but protoc-c still use scoped_array, caused compile error. 2. fix compile error since missing namespace 3. from protobuf 3.6, only C++11 is supported, so set to use c++11 for protobuf-c Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb b/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
index 9b696906e8..209bb47e8e 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
@@ -15,10 +15,16 @@ DEPENDS = "protobuf-native protobuf"
PV .= "+git${SRCPV}"
SRCREV = "dac1a65feac4ad72f612aab99f487056fbcf5c1a"
-SRC_URI = "git://github.com/protobuf-c/protobuf-c.git"
+SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \
+ file://0001-protobuf-c-fix-compile-error-with-protobuf-3.6.0.1.patch \
+"
S = "${WORKDIR}/git"
+#make sure c++11 is used
+CXXFLAGS += "-std=c++11"
+BUILD_CXXFLAGS += "-std=c++11"
+
inherit autotools pkgconfig
PACKAGE_BEFORE_PN = "${PN}-compiler"