aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php
diff options
context:
space:
mode:
authorKonrad Weihmann <kweihmann@outlook.com>2020-05-03 16:02:24 +0200
committerKhem Raj <raj.khem@gmail.com>2020-05-04 12:15:50 -0700
commit171b924a1f6eda1e602e117d62483386175bddc3 (patch)
treeede2a1738c903a36c516aa7e64b0632f5e3400aa /meta-oe/recipes-devtools/php
parent6690afa59e5bb698e752c3346b8470e40f9d9daa (diff)
downloadmeta-openembedded-contrib-171b924a1f6eda1e602e117d62483386175bddc3.tar.gz
php: add multibyte string support config
Add mbstring to PACKAGECONFIG to enable multibyte string support in php Signed-off-by: Konrad Weihmann <kweihmann@outlook.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r--meta-oe/recipes-devtools/php/php_7.4.4.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php_7.4.4.bb b/meta-oe/recipes-devtools/php/php_7.4.4.bb
index c1784a78d9..53cda40fbb 100644
--- a/meta-oe/recipes-devtools/php/php_7.4.4.bb
+++ b/meta-oe/recipes-devtools/php/php_7.4.4.bb
@@ -105,6 +105,7 @@ PACKAGECONFIG[opcache] = "--enable-opcache,--disable-opcache"
PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
PACKAGECONFIG[valgrind] = "--with-valgrind=${STAGING_DIR_TARGET}/usr,--with-valgrind=no,valgrind"
PACKAGECONFIG[mbregex] = "--enable-mbregex, --disable-mbregex, oniguruma"
+PACKAGECONFIG[mbstring] = "--enable-mbstring,,"
export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
export PHP_PEAR_PHP_BIN = "${STAGING_BINDIR_NATIVE}/php"