aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-devtools/php
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r--meta-oe/recipes-devtools/php/php.inc10
-rw-r--r--meta-oe/recipes-devtools/php/php/phar-makefile.patch8
-rw-r--r--meta-oe/recipes-devtools/php/php_5.3.19.bb2
3 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc
index 29e82fa716..176d4a1c54 100644
--- a/meta-oe/recipes-devtools/php/php.inc
+++ b/meta-oe/recipes-devtools/php/php.inc
@@ -30,15 +30,15 @@ EXTRA_OECONF = "--enable-mbstring --enable-discard-path --enable-wddx \
--disable-embedded-mysqli \
--with-mysql="${STAGING_DIR_TARGET}${prefix}" \
--with-mysqli="${STAGING_BINDIR_CROSS}/mysql_config" \
- --with-sqlite3=${STAGING_LIBDIR}/.. --enable-sqlite-utf8 \
+ --with-sqlite3=${STAGING_LIBDIR}/.. --enable-sqlite-utf8 \
--with-pdo-mysql="${STAGING_BINDIR_CROSS}/mysql_config" \
--with-pdo-sqlite=${STAGING_LIBDIR}/.. ${COMMON_EXTRA_OECONF} \
- "
+"
EXTRA_OECONF_virtclass-native = "--with-cgi --without-libpng --without-libjpeg \
--with-zlib --with-zlib-dir=${STAGING_LIBDIR_NATIVE}/.. \
--with-libxml-dir=${STAGING_BINDIR_NATIVE} \
${COMMON_EXTRA_OECONF} \
- "
+"
LIBS_virtclass-native = " -lxml2 "
LIBS_pn-php =" -lpthread "
@@ -82,8 +82,8 @@ do_install_append_pn-php() {
install -m 0755 ${S}/sapi/fpm/init.d.php-fpm ${D}${sysconfdir}/init.d/php-fpm
TMP=`dirname ${D}/${TMPDIR}`
while test ${TMP} != ${D}; do
- rmdir ${TMP}
- TMP=`dirname ${TMP}`;
+ rmdir ${TMP}
+ TMP=`dirname ${TMP}`;
done
}
diff --git a/meta-oe/recipes-devtools/php/php/phar-makefile.patch b/meta-oe/recipes-devtools/php/php/phar-makefile.patch
index 6fde251275..9d1dc7b9ae 100644
--- a/meta-oe/recipes-devtools/php/php/phar-makefile.patch
+++ b/meta-oe/recipes-devtools/php/php/phar-makefile.patch
@@ -4,8 +4,8 @@ index fc93d1d..9a8cd65 100755
+++ b/ext/phar/Makefile.frag
@@ -6,19 +6,8 @@ pharcmd: $(builddir)/phar.php $(builddir)/phar.phar
- PHP_PHARCMD_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0 -d 'safe_mode=0'
- PHP_PHARCMD_EXECUTABLE = ` \
+ PHP_PHARCMD_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0 -d 'safe_mode=0'
+ PHP_PHARCMD_EXECUTABLE = ` \
- if test -x "$(top_builddir)/$(SAPI_CLI_PATH)"; then \
- $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
- if test "x$(PHP_MODULES)" != "x"; then \
@@ -21,6 +21,6 @@ index fc93d1d..9a8cd65 100755
- fi;`
+ $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; `
+
- PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
+ PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
- $(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
+ $(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
diff --git a/meta-oe/recipes-devtools/php/php_5.3.19.bb b/meta-oe/recipes-devtools/php/php_5.3.19.bb
index 8204104b7f..0ce811300b 100644
--- a/meta-oe/recipes-devtools/php/php_5.3.19.bb
+++ b/meta-oe/recipes-devtools/php/php_5.3.19.bb
@@ -16,7 +16,7 @@ SRC_URI_append_pn-php += "file://iconv.patch \
file://fix-fpm-cross-compile.patch \
file://php-fpm.conf \
file://php-fpm-apache.conf \
- "
+"
SRC_URI[md5sum] = "e1d2a3ec7849d4b3032bd1abf1916aa4"
SRC_URI[sha256sum] = "814ce55b950158c4ddadbcd0b2d7d8cb4b570de4a29b9db021020594e2469fd6"