aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-07-01 09:24:26 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-16 21:09:08 +0200
commit110d71ac10492599c8ba0f348e9058c53c28b7ac (patch)
treee945c44e38a792b5d5e2ca73f2a22d06710d902f /meta-oe/recipes-devtools/php
parent327186e4c9c9b54497c24a5da32ed5978cb66477 (diff)
downloadmeta-openembedded-contrib-110d71ac10492599c8ba0f348e9058c53c28b7ac.tar.gz
php: fix a building failure on aarch64
When -O0 of gcc is used to compile the macro ZEND_SIGNED_MULTIPLY_LONG in Zend/zend_multiply.h, the compiling will fail with the below error: : Assembler messages: :3113: Error: operand 2 should be an integer register -- `mul x1,[x29,200],[x29,192]' :3114: Error: operand 2 should be an integer register -- `smulh x0,[x29,200],[x29,192]' Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r--meta-oe/recipes-devtools/php/php_5.5.26.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php_5.5.26.bb b/meta-oe/recipes-devtools/php/php_5.5.26.bb
index 8b64b2bd4b..85fdccb473 100644
--- a/meta-oe/recipes-devtools/php/php_5.5.26.bb
+++ b/meta-oe/recipes-devtools/php/php_5.5.26.bb
@@ -101,6 +101,7 @@ PACKAGECONFIG[imap] = "--with-imap=${STAGING_DIR_HOST} \
export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
export PHP_PEAR_PHP_BIN = "${STAGING_BINDIR_NATIVE}/php"
CFLAGS += " -D_GNU_SOURCE -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR}/apache2"
+CFLAGS_append_aarch64 = " -O2"
EXTRA_OEMAKE = "INSTALL_ROOT=${D}"