aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-25 21:22:33 -0700
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commit1cc3395a74a2bcce5e844e17cebb88bb8064eb3a (patch)
tree1031df8c7e53c703a49bbac776e074eea6164820 /meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb
parent6e3c73615bfad9ac127c3e9336af7714c9e9fde1 (diff)
downloadmeta-openembedded-contrib-1cc3395a74a2bcce5e844e17cebb88bb8064eb3a.tar.gz
libdbi-perl: upgrade v1.639 -> v1.641; inherit ptest-perl
* Remove tests that require "-T" (taint) * Remove 85gofer.t test, failure mode unclear * Remove duplicate tests * Use LICENSE file for checksum - License remains the same License-Update: use LICENSE file for checksum Upstream release notes: Changes in DBI 1.641 - 19th March 2018 Remove dependency on Storable 2.16 introduced in DBI 1.639 thanks to Ribasushi #60 Avoid compiler warnings in Driver.xst #59 thanks to pali #59 Changes in DBI 1.640 - 28th January 2018 Fix test t/91_store_warning.t for perl 5.10.0 thanks to pali #57 Add Perl 5.10.0 and 5.8.1 specific versions to Travis testing thanks to pali #57 Add registration of mariadb_ prefix for new DBD::MariaDB driver thanks to pali #56 Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb')
-rw-r--r--meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb b/meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb
new file mode 100644
index 0000000000..24a1245fc0
--- /dev/null
+++ b/meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb
@@ -0,0 +1,36 @@
+SUMMARY = "The Perl Database Interface"
+DESCRIPTION = "DBI is a database access Application Programming Interface \
+(API) for the Perl Language. The DBI API Specification defines a set \
+of functions, variables and conventions that provide a consistent \
+database interface independent of the actual database being used. \
+"
+HOMEPAGE = "http://search.cpan.org/dist/DBI/"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+RDEPENDS_${PN} = " perl-module-carp \
+ perl-module-exporter \
+ perl-module-exporter-heavy \
+ perl-module-dynaloader \
+"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
+SRC_URI[md5sum] = "e77fd37fcf77fc88fde029c1b75ded54"
+SRC_URI[sha256sum] = "5509e532cdd0e3d91eda550578deaac29e2f008a12b64576e8c261bb92e8c2c1"
+
+S = "${WORKDIR}/DBI-${PV}"
+
+inherit cpan ptest-perl
+
+do_install_prepend() {
+ # test requires "-T" (taint) command line option
+ rm -rf ${B}/t/pod-coverage.t
+ rm -rf ${B}/t/13taint.t
+ # source of test failure not obvious
+ rm -rf ${B}/t/85gofer.t
+ # unclear why there are several duplicates of tests in tarball
+ rm -rf ${B}/t/z*.t
+}
+
+BBCLASSEXTEND = "native"