aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/perl/ipc-run_0.96.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2018-02-05 13:40:48 +0800
committerArmin Kuster <akuster808@gmail.com>2018-02-23 20:19:52 -0800
commit7ec2989fc0bb7fe16a2394aa49a09e1f428fd8b1 (patch)
treec29ec3085925c60a63d1989d8c31e9c70dee9741 /meta-oe/recipes-devtools/perl/ipc-run_0.96.bb
parentf5f7c242d47ae99fca44a06277e4cdc6bc0cec6b (diff)
downloadmeta-openembedded-contrib-7ec2989fc0bb7fe16a2394aa49a09e1f428fd8b1.tar.gz
ipc-run: 0.94 -> 0.96
Upgrade ipc-run from 0.94 to 0.96. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/perl/ipc-run_0.96.bb')
-rw-r--r--meta-oe/recipes-devtools/perl/ipc-run_0.96.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perl/ipc-run_0.96.bb b/meta-oe/recipes-devtools/perl/ipc-run_0.96.bb
new file mode 100644
index 0000000000..08c966da9d
--- /dev/null
+++ b/meta-oe/recipes-devtools/perl/ipc-run_0.96.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "\
+IPC::Run allows you run and interact with child processes \
+using files, pipes, and pseudo-ttys. Both system()-style and scripted \
+usages are supported and may be mixed. Likewise, functional and OO API \
+styles are both supported and may be mixed."
+HOMEPAGE = "https://metacpan.org/release/IPC-Run"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e"
+DEPENDS = "perl"
+
+SRC_URI = "git://github.com/toddr/IPC-Run.git"
+SRCREV = "96066366ac8c401dff9c979d04f25dc8219ffcc1"
+
+S = "${WORKDIR}/git"
+
+inherit cpan
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}