aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/packagegroups
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-09-04 14:11:58 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-05 10:05:06 +0200
commit21a4be0e36bb1ee6c3c469c83a623c5d9a45257a (patch)
treebe14375786b4756c8c9d62020cc99a8b2da808fa /meta-oe/recipes-devtools/packagegroups
parentf3dbc97b44a5dd2588eb0c6ed7e3ce1b1e997847 (diff)
downloadmeta-openembedded-contrib-21a4be0e36bb1ee6c3c469c83a623c5d9a45257a.tar.gz
task*: rename to packagegroup to match oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/packagegroups')
-rw-r--r--meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb b/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
new file mode 100644
index 0000000000..3ad9b55577
--- /dev/null
+++ b/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Packages required for a target (on-device) SDK"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+inherit packagegroup allarch
+
+RPROVIDES_${PN} = "packagegroup-native-sdk"
+RDEPENDS_${PN} = "gcc-symlinks g++-symlinks cpp cpp-symlinks \
+ binutils-symlinks \
+ perl-modules \
+ flex flex-dev \
+ bison \
+ gawk \
+ sed \
+ grep \
+ autoconf automake \
+ make \
+ patch diffstat diffutils \
+ libstdc++-dev \
+ libtool libtool-dev libltdl-dev \
+ pkgconfig"
+
+# usefull, but not in oe-core/meta-oe yet: patchutils
+RRECOMMENDS_${PN} = " g77-symlinks gfortran-symlinks"