aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-16 14:47:30 -0700
committerKhem Raj <raj.khem@gmail.com>2021-04-21 08:27:01 -0700
commitf52863f02c4c3e6aae3e25dff254955216cdc0a3 (patch)
treef2c8a35fd41551cd4f266d5c78e0ac6fc5a08387 /meta-oe/recipes-devtools/nodejs
parent3f61a4c881f9ad59c39197051970e393a9435900 (diff)
downloadmeta-openembedded-contrib-f52863f02c4c3e6aae3e25dff254955216cdc0a3.tar.gz
nodejs: Use qemu usermode to run target binaries during build
So far, we have been trying to build nodejs-native and use the native host binaries from there, which has worked out ok but always changes when major upgrade is done, since more binaries or places are required to be captured. This patch changes this approach to use qemu-user to run these binaries under during cross build. This lets them run closer to upstream build process and also removes dependency on nodejs-native Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-binaries.patch93
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_14.16.1.bb34
2 files changed, 74 insertions, 53 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-binaries.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-binaries.patch
index b5142dc9c1..c6fc2dcd76 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-binaries.patch
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0002-Using-native-binaries.patch
@@ -8,64 +8,55 @@ Subject: [PATCH] Using native binaries
tools/v8_gypfiles/v8.gyp | 11 ++++-------
2 files changed, 6 insertions(+), 9 deletions(-)
-diff --git a/node.gyp b/node.gyp
-index 8f4dc518..d9389190 100644
--- a/node.gyp
+++ b/node.gyp
-@@ -446,7 +446,7 @@
- '<(SHARED_INTERMEDIATE_DIR)/node_code_cache.cc',
+@@ -487,6 +487,7 @@
+ 'action_name': 'run_mkcodecache',
+ 'process_outputs_as_sources': 1,
+ 'inputs': [
++ '<(PRODUCT_DIR)/v8-qemu-wrapper.sh',
+ '<(mkcodecache_exec)',
],
- 'action': [
-- '<@(_inputs)',
-+ 'mkcodecache',
- '<@(_outputs)',
+ 'outputs': [
+@@ -512,6 +513,7 @@
+ 'action_name': 'node_mksnapshot',
+ 'process_outputs_as_sources': 1,
+ 'inputs': [
++ '<(PRODUCT_DIR)/v8-qemu-wrapper.sh',
+ '<(node_mksnapshot_exec)',
],
- },
-@@ -471,7 +471,7 @@
- '<(SHARED_INTERMEDIATE_DIR)/node_snapshot.cc',
- ],
- 'action': [
-- '<@(_inputs)',
-+ 'node_mksnapshot',
- '<@(_outputs)',
- ],
- },
-diff --git a/tools/v8_gypfiles/v8.gyp b/tools/v8_gypfiles/v8.gyp
-index a506a67d..c91f7dde 100644
+ 'outputs': [
--- a/tools/v8_gypfiles/v8.gyp
+++ b/tools/v8_gypfiles/v8.gyp
-@@ -140,7 +140,8 @@
- '<@(torque_outputs)',
- ],
- 'action': [
-- '<@(_inputs)',
-+ 'torque',
-+ '<@(torque_files)',
- '-o', '<(torque_output_root)/torque-generated',
- '-v8-root', '<(V8_ROOT)'
+@@ -220,6 +220,7 @@
+ {
+ 'action_name': 'run_torque_action',
+ 'inputs': [ # Order matters.
++ '<(PRODUCT_DIR)/v8-qemu-wrapper.sh',
+ '<(PRODUCT_DIR)/<(EXECUTABLE_PREFIX)torque<(EXECUTABLE_SUFFIX)',
+ '<@(torque_files)',
],
-@@ -247,9 +248,7 @@
- '<(generate_bytecode_builtins_list_output)',
+@@ -351,6 +352,7 @@
+ {
+ 'action_name': 'generate_bytecode_builtins_list_action',
+ 'inputs': [
++ '<(PRODUCT_DIR)/v8-qemu-wrapper.sh',
+ '<(PRODUCT_DIR)/<(EXECUTABLE_PREFIX)bytecode_builtins_list_generator<(EXECUTABLE_SUFFIX)',
],
- 'action': [
-- 'python',
-- '<(V8_ROOT)/tools/run.py',
-- '<@(_inputs)',
-+ 'bytecode_builtins_list_generator',
- '<@(_outputs)',
+ 'outputs': [
+@@ -533,6 +535,7 @@
+ ],
+ },
+ 'inputs': [
++ '<(PRODUCT_DIR)/v8-qemu-wrapper.sh',
+ '<(mksnapshot_exec)',
],
- },
-@@ -1396,9 +1395,7 @@
- '<(SHARED_INTERMEDIATE_DIR)/src/regexp/special-case.cc',
+ 'outputs': [
+@@ -1448,6 +1451,7 @@
+ {
+ 'action_name': 'run_gen-regexp-special-case_action',
+ 'inputs': [
++ '<(PRODUCT_DIR)/v8-qemu-wrapper.sh',
+ '<(PRODUCT_DIR)/<(EXECUTABLE_PREFIX)gen-regexp-special-case<(EXECUTABLE_SUFFIX)',
],
- 'action': [
-- 'python',
-- '<(V8_ROOT)/tools/run.py',
-- '<@(_inputs)',
-+ 'gen-regexp-special-case',
- '<@(_outputs)',
- ],
- },
---
-2.20.1
-
+ 'outputs': [
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_14.16.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_14.16.1.bb
index 32bdd713b5..aef83cc31c 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_14.16.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_14.16.1.bb
@@ -4,9 +4,9 @@ LICENSE = "MIT & BSD & Artistic-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=85bf260d8b6de1588f57abc5dc66587c"
DEPENDS = "openssl"
-DEPENDS_append_class-target = " nodejs-native"
+DEPENDS_append_class-target = " qemu-native"
-inherit pkgconfig python3native
+inherit pkgconfig python3native qemu
COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*"
COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*"
@@ -93,6 +93,35 @@ python do_unpack() {
shutil.rmtree(d.getVar('S') + '/deps/zlib', True)
}
+# V8's JIT infrastructure requires binaries such as mksnapshot and
+# mkpeephole to be run in the host during the build. However, these
+# binaries must have the same bit-width as the target (e.g. a x86_64
+# host targeting ARMv6 needs to produce a 32-bit binary). Instead of
+# depending on a third Yocto toolchain, we just build those binaries
+# for the target and run them on the host with QEMU.
+python do_create_v8_qemu_wrapper () {
+ """Creates a small wrapper that invokes QEMU to run some target V8 binaries
+ on the host."""
+ qemu_libdirs = [d.expand('${STAGING_DIR_HOST}${libdir}'),
+ d.expand('${STAGING_DIR_HOST}${base_libdir}')]
+ qemu_cmd = qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST', True),
+ qemu_libdirs)
+ wrapper_path = d.expand('${B}/v8-qemu-wrapper.sh')
+ with open(wrapper_path, 'w') as wrapper_file:
+ wrapper_file.write("""#!/bin/sh
+
+# This file has been generated automatically.
+# It invokes QEMU to run binaries built for the target in the host during the
+# build process.
+
+%s "$@"
+""" % qemu_cmd)
+ os.chmod(wrapper_path, 0o755)
+}
+
+do_create_v8_qemu_wrapper[dirs] = "${B}"
+addtask create_v8_qemu_wrapper after do_configure before do_compile
+
# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
do_configure () {
export LD="${CXX}"
@@ -110,6 +139,7 @@ do_configure () {
do_compile () {
export LD="${CXX}"
+ install -Dm 0755 ${B}/v8-qemu-wrapper.sh ${B}/out/Release/v8-qemu-wrapper.sh
oe_runmake BUILDTYPE=Release
}