aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs
diff options
context:
space:
mode:
authorJaga <jagadheesan_duraisamy@comcast.com>2020-03-12 15:49:21 +0000
committerKhem Raj <raj.khem@gmail.com>2020-03-12 09:58:05 -0700
commite331ce08e417859a7e8028cd691a6674cf6ed1d9 (patch)
tree6af38122ca138ad24a69065ec09389e10e4330a7 /meta-oe/recipes-devtools/nodejs
parenta12959c75ecb8f5d66e29d26a3987fc481d992c3 (diff)
downloadmeta-openembedded-contrib-e331ce08e417859a7e8028cd691a6674cf6ed1d9.tar.gz
nodejs: install gen-regexp-special-case only when icu is enabled
Fixes install errors when icu packageconfig is disabled Signed-off-by: Jaga <jagadheesan_duraisamy@comcast.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb
index 1ea438c5b0..a482c6b4ca 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb
@@ -138,7 +138,9 @@ do_install_append_class-native() {
install -d ${D}${bindir}
install -m 0755 ${S}/out/Release/torque ${D}${bindir}/torque
install -m 0755 ${S}/out/Release/bytecode_builtins_list_generator ${D}${bindir}/bytecode_builtins_list_generator
- install -m 0755 ${S}/out/Release/gen-regexp-special-case ${D}${bindir}/gen-regexp-special-case
+ if ${@bb.utils.contains('PACKAGECONFIG','icu','true','false',d)}; then
+ install -m 0755 ${S}/out/Release/gen-regexp-special-case ${D}${bindir}/gen-regexp-special-case
+ fi
install -m 0755 ${S}/out/Release/mkcodecache ${D}${bindir}/mkcodecache
install -m 0755 ${S}/out/Release/node_mksnapshot ${D}${bindir}/node_mksnapshot
}