aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-10-29 16:42:24 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-01 17:22:52 -0700
commit76dd3dac1f1e67a5c44ad732b8e827cc36ded641 (patch)
tree388a93775ebb2bcdd1680b1ce39a6983f37aab5a /meta-oe/recipes-devtools/nodejs
parentb70b263add2a2f1a4964bbc39400bccd13c4056d (diff)
downloadmeta-openembedded-contrib-76dd3dac1f1e67a5c44ad732b8e827cc36ded641.tar.gz
nodejs: allow use of system c-ares (and make default)
Use system c-ares via PACKAGECONFIG by default. So far, nodejs had been built using its embedded copy of c-ares, which we generally try to avoid, for the known reasons (independent updates, cve & license checks, etc). Notes: * otherwise nodejs uses its bundled version of c-ares * the PACKAGECONFIG variable is 'ares' so as to be in line with other uses of this (wget & curl recipes in OE core) Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.16.3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.16.3.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.16.3.bb
index a978eebe47..97a1967cc2 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_10.16.3.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.16.3.bb
@@ -52,9 +52,10 @@ ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '-
GYP_DEFINES_append_mipsel = " mips_arch_variant='r1' "
ARCHFLAGS ?= ""
-PACKAGECONFIG ??= "zlib icu"
-PACKAGECONFIG[zlib] = "--shared-zlib,,zlib"
+PACKAGECONFIG ??= "ares icu zlib"
+PACKAGECONFIG[ares] = "--shared-cares,,c-ares"
PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
+PACKAGECONFIG[zlib] = "--shared-zlib,,zlib"
# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
do_configure () {