aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2020-03-03 18:22:36 +0000
committerKhem Raj <raj.khem@gmail.com>2020-03-03 11:40:40 -0800
commit754b54699b881459eda3eaf4e2ba893e85b76abf (patch)
treec1a3cdff50127af19bce7bec8d9cecac37456317 /meta-oe/recipes-devtools/nodejs
parentd5cf4a0041d1c53ebb2c9baa5b3a17c6af41b5b9 (diff)
downloadmeta-openembedded-contrib-754b54699b881459eda3eaf4e2ba893e85b76abf.tar.gz
nodejs: drop 'gyp' PACKAGECONFIG
During the python3 / nodejs update, the dependencies weren't updated, so using system-gyp ends up trying to use the python2 version of system- gyp, which will of course fail. Fixing this to depend on the python3 version of gyp still doesn't doesn't make things work, though: ERROR: nodejs-native-12.14.1-r0 do_configure: Execution of '.../nodejs-native/12.14.1-r0/temp/run.do_configure.26054' failed with exit code 1: gyp: Error importing pymod_do_mainmodule (ForEachFormat): No module named 'ForEachFormat' while loading dependencies of .../nodejs-native/12.14.1-r0/node-v12.14.1/node.gyp while trying to load .../nodejs-native/12.14.1-r0/node-v12.14.1/node.gyp Error running GYP The reason is commit fff922afee6e ("deps,build: compute torque_outputs in v8.gyp") in NodeJS v12, where they modified their bundled version of gyp to become incompatible with the upstream version of gyp by adding extra / unusual search paths to gyp. Since I'm not sure how to deal with that when using system-gyp, and because the original intention for using system-gyp was to make the previous nodejs version compatible with python3 by ultimately switching to the python3 version of system-gyp which isn't necessary anymore, and given nobody else seems to be using this PACKAGECONFIG, just drop it. Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb3
1 files changed, 0 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb
index 6eb52c209a..49bb71e282 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb
@@ -53,7 +53,6 @@ ARCHFLAGS ?= ""
PACKAGECONFIG ??= "ares icu libuv zlib"
PACKAGECONFIG[ares] = "--shared-cares,,c-ares"
-PACKAGECONFIG[gyp] = ",,gyp-py2-native"
PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
PACKAGECONFIG[libuv] = "--shared-libuv,,libuv"
PACKAGECONFIG[nghttp2] = "--shared-nghttp2,,nghttp2"
@@ -82,8 +81,6 @@ python do_unpack() {
shutil.rmtree(d.getVar('S') + '/deps/openssl', True)
if 'ares' in d.getVar('PACKAGECONFIG'):
shutil.rmtree(d.getVar('S') + '/deps/cares', True)
- if 'gyp' in d.getVar('PACKAGECONFIG'):
- shutil.rmtree(d.getVar('S') + '/tools/gyp', True)
if 'libuv' in d.getVar('PACKAGECONFIG'):
shutil.rmtree(d.getVar('S') + '/deps/uv', True)
if 'nghttp2' in d.getVar('PACKAGECONFIG'):