aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-04-01 10:06:38 -0500
committerKhem Raj <raj.khem@gmail.com>2021-04-02 02:03:57 -0700
commit649fb54245a2cb330ee6f78ab28c917492760f76 (patch)
treec3d6ad0daa12c92ba3e0c0c8a8cc37a39f0f89bb /meta-oe/recipes-devtools/nodejs
parent5f3159f6349e5e1a1b134b2997d7dc62daaf2ef7 (diff)
downloadmeta-openembedded-contrib-649fb54245a2cb330ee6f78ab28c917492760f76.tar.gz
nodejs: ppc64le machine support
Commit 836912ab changed the logic in this recipe to stop looking for "ppc64le". This caused the ppc64le systems used by me to stop working. There wasn't much in the commit message on why this change occurred but ppc64le is definitely still needed. Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_12.21.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_12.21.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_12.21.0.bb
index 3a2822c38d..9b86bf3373 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_12.21.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_12.21.0.bb
@@ -39,7 +39,7 @@ def map_nodejs_arch(a, d):
if re.match('i.86$', a): return 'ia32'
elif re.match('x86_64$', a): return 'x64'
elif re.match('aarch64$', a): return 'arm64'
- elif re.match('(powerpc64|powerpc64le)$', a): return 'ppc64'
+ elif re.match('(powerpc64|powerpc64le|ppc64le)$', a): return 'ppc64'
elif re.match('powerpc$', a): return 'ppc'
return a