aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2017-10-17 23:50:09 +1100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-27 16:39:33 +0000
commit09d5d09762be59ad374f0da9e4a37063e179a726 (patch)
treea3d482da8400c4a90e72a9a968052b33c8d412be /meta-oe/recipes-devtools/nodejs
parent0d220e002e4f525469f0c24e0585318d2178e7a1 (diff)
downloadmeta-openembedded-contrib-09d5d09762be59ad374f0da9e4a37063e179a726.tar.gz
nodejs: Remove unreferenced patches
Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r--meta-oe/recipes-devtools/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch29
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/no-registry.patch59
2 files changed, 0 insertions, 88 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch b/meta-oe/recipes-devtools/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
deleted file mode 100644
index 324a4683d6..0000000000
--- a/meta-oe/recipes-devtools/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From c2aff16cc196a61f4ab1cdae4a91c7926123c239 Mon Sep 17 00:00:00 2001
-From: Zuzana Svetlikova <zsvetlik@redhat.com>
-Date: Thu, 27 Apr 2017 14:25:42 +0200
-Subject: [PATCH] Disable running gyp on shared deps
-
----
- Makefile | 7 +++----
- 1 file changed, 3 insertions(+), 4 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 0a217bd893..e1229ad07f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -79,10 +79,9 @@ $(NODE_G_EXE): config.gypi out/Makefile
- $(MAKE) -C out BUILDTYPE=Debug V=$(V)
- if [ ! -r $@ -o ! -L $@ ]; then ln -fs out/Debug/$(NODE_EXE) $@; fi
-
--out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
-- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
-- deps/v8/gypfiles/features.gypi deps/v8/src/v8.gyp node.gyp \
-- config.gypi
-+out/Makefile: common.gypi deps/http_parser/http_parser.gyp \
-+ deps/v8/gypfiles/toolchain.gypi deps/v8/gypfiles/features.gypi \
-+ deps/v8/src/v8.gyp node.gyp config.gypi
- $(PYTHON) tools/gyp_node.py -f make
-
- config.gypi: configure
---
-2.12.2
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/no-registry.patch b/meta-oe/recipes-devtools/nodejs/nodejs/no-registry.patch
deleted file mode 100644
index ed24738976..0000000000
--- a/meta-oe/recipes-devtools/nodejs/nodejs/no-registry.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-Bugfix for --no-registry in nodejs-v0.12.2
-
-diff -u -r node-v0.12.2_def/deps/npm/lib/cache/caching-client.js node-v0.12.2/deps/npm/lib/cache/caching-client.js
---- node-v0.12.2_def/deps/npm/lib/cache/caching-client.js 2015-04-01 01:13:01.000000000 +0300
-+++ node-v0.12.2/deps/npm/lib/cache/caching-client.js 2015-05-18 00:47:10.738599686 +0300
-@@ -67,6 +67,22 @@
- var cacheBase = cacheFile(npm.config.get("cache"))(uri)
- var cachePath = path.join(cacheBase, ".cache.json")
-
-+ if (parsed.host === "noregistry") (function() {
-+ var stat = null
-+ var file = npm.config.get("cache") + parsed.pathname + "/.cache.json"
-+ try {
-+ stat = fs.statSync(cachePath)
-+ } catch (ex) {}
-+ if (!stat) try {
-+ stat = fs.statSync(file)
-+ cachePath = file
-+ } catch (ex) {
-+ stat = "Registry not defined and registry files not found: \"" +
-+ cachePath + "\", \"" + file + "\"."
-+ throw new Error(stat)
-+ }
-+ })()
-+
- // If the GET is part of a write operation (PUT or DELETE), then
- // skip past the cache entirely, but still save the results.
- if (uri.match(/\?write=true$/)) {
-@@ -83,12 +99,17 @@
- }
- catch (ex) {
- data = null
-+ if (parsed.host === "noregistry")
-+ throw new Error("File \"" + cachePath+"\"" + " corrupted.")
- }
-
- params.stat = stat
- params.data = data
-
-- get_.call(client, uri, cachePath, params, cb)
-+ if (parsed.host === "noregistry")
-+ cb(null, data, JSON.stringify(data), { statusCode : 304 })
-+ else
-+ get_.call(client, uri, cachePath, params, cb)
- })
- }
- else {
-diff -u -r node-v0.12.2_def/deps/npm/lib/utils/map-to-registry.js node-v0.12.2/deps/npm/lib/utils/map-to-registry.js
---- node-v0.12.2_def/deps/npm/lib/utils/map-to-registry.js 2015-04-01 01:13:01.000000000 +0300
-+++ node-v0.12.2/deps/npm/lib/utils/map-to-registry.js 2015-05-18 01:15:10.030569613 +0300
-@@ -45,6 +45,8 @@
-
- log.silly("mapToRegistry", "registry", registry)
-
-+ if (!registry) return cb(null, "http://noregistry/" + name, {})
-+
- var auth = config.getCredentialsByURI(registry)
-
- // normalize registry URL so resolution doesn't drop a piece of registry URL