aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.2.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-09-06 09:14:28 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-05 22:19:55 -0700
commit5bfa82d1026dbd02383511d516679111fb8bc5de (patch)
treeb72ec6b30798aa594563564b4c1d115cef002177 /meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.2.bb
parent88f1b1309718246815e00da899853f622bc46bb8 (diff)
downloadmeta-openembedded-contrib-5bfa82d1026dbd02383511d516679111fb8bc5de.tar.gz
nlohmann-json: upgrade 3.9.1 -> 3.10.2
Release date: 2021-08-26 SHA-256: 059743e48b37e41579ee3a92e82e984bfa0d2a9a2b20b175d04db8089f46f047 (json.hpp) 61e605be15e88deeac4582aaf01c09d616f8302edde7adcaba9261ddc3b4ceca (include.zip) Summary This release is made days after the 3.10.1 release due to a bug in the release script: The 3.10.1 release at GitHub contained the correct files, but the associated tag v3.10.1 points to the wrong commit. This release is made with a fixed build script. All changes are backward-compatible. Improvements Fix the release scripts to correctly tag releases. https://github.com/nlohmann/json/issues/2973 Fix some -Wunused warnings on JSON_DIAGNOSTICS when the library is built without CMake. https://github.com/nlohmann/json/issues/2975 https://github.com/nlohmann/json/pull/2976 Deprecated functions Passing iterator pairs or pointer/length pairs to parsing functions (basic_json::parse, basic_json::accept, basic_json::sax_parse, basic_json::from_cbor, basic_json::from_msgpack, basic_json::from_ubjson, basic_json::from_bson) via initializer lists is deprecated. Instead, pass two iterators; for instance, call basic_json::from_cbor(ptr, ptr+len) instead of basic_json::from_cbor({ptr, len}). -License-Update: Copyright year updated to 2021. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.2.bb')
-rw-r--r--meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.2.bb b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.2.bb
new file mode 100644
index 0000000000..d2015771ac
--- /dev/null
+++ b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.2.bb
@@ -0,0 +1,28 @@
+SUMMARY = "JSON for modern C++"
+HOMEPAGE = "https://nlohmann.github.io/json/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=441793d25a658d58d79a1f87516a6ad1"
+
+SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \
+ "
+
+SRCREV = "626e7d61e44dee32887126c8f437dd077dec09cf"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
+
+# nlohmann-json is a header only C++ library, so the main package will be empty.
+
+RDEPENDS:${PN}-dev = ""
+
+BBCLASSEXTEND = "native nativesdk"
+
+# other packages commonly reference the file directly as "json.hpp"
+# create symlink to allow this usage
+do_install:append() {
+ ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
+}