aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-03 02:01:06 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:35 -0700
commita7dddae00cfb4e7c9ee73afc7f6561e239478fa7 (patch)
treec989e5fbeeef9f7fd1f5d2ded4dd620053c3f0a3 /meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb
parentaca683fb18c3a62874e6687e36fb4c35a25d0615 (diff)
downloadmeta-openembedded-contrib-a7dddae00cfb4e7c9ee73afc7f6561e239478fa7.tar.gz
nlohmann-fifo: Disable cpp11 shuffle with clang/libc++
it does not compile with clang15 based libc++ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb')
-rw-r--r--meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb b/meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb
index 5a130ebda4..b5d05d40e5 100644
--- a/meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb
+++ b/meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb
@@ -20,6 +20,9 @@ RDEPENDS:${PN}-dev = ""
BBCLASSEXTEND = "native nativesdk"
+# See https://github.com/SOCI/soci/issues/984
+CXXFLAGS:append:toolchain-clang:runtime-llvm = " -DCATCH_CONFIG_CPP11_NO_SHUFFLE"
+
do_install() {
install -d ${D}${includedir}
install -m 0644 ${S}/src/fifo_map.hpp ${D}${includedir}