aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/mpich
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-devtools/mpich
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/mpich')
-rw-r--r--meta-oe/recipes-devtools/mpich/mpich_3.4.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/mpich/mpich_3.4.2.bb b/meta-oe/recipes-devtools/mpich/mpich_3.4.2.bb
index 20df3620d0..3fe32f8c94 100644
--- a/meta-oe/recipes-devtools/mpich/mpich_3.4.2.bb
+++ b/meta-oe/recipes-devtools/mpich/mpich_3.4.2.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=bd4d7ab13df98988b1ca2a4e01c8c163"
SRC_URI = "http://www.mpich.org/static/downloads/${PV}/mpich-${PV}.tar.gz"
SRC_URI[sha256sum] = "5c19bea8b84e8d74cca5f047e82b147ff3fba096144270e3911ad623d6c587bf"
-RDEPENDS_${PN} += "bash perl libxml2"
+RDEPENDS:${PN} += "bash perl libxml2"
EXTRA_OECONF = "--enable-debuginfo \
--enable-fast \
@@ -31,8 +31,8 @@ PACKAGECONFIG += " \
"
PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
-LDFLAGS_append_libc-glibc_x86-64 = " -lgcc"
-LDFLAGS_append_libc-glibc_x86 = " -lgcc"
+LDFLAGS:append:libc-glibc:x86-64 = " -lgcc"
+LDFLAGS:append:libc-glibc:x86 = " -lgcc"
inherit autotools gettext pkgconfig
@@ -51,7 +51,7 @@ do_configure() {
oe_runconf
}
-do_install_append() {
+do_install:append() {
sed -i 's,${S}/,,g' ${D}/${libdir}/libmpi.la
sed -i 's,${DEBUG_PREFIX_MAP},,g' ${D}/${libdir}/pkgconfig/mpich.pc
}