aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/mpich
diff options
context:
space:
mode:
authorVictor Rodriguez <victor.rodriguez.bahena@intel.com>2015-03-09 14:57:43 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-21 16:42:21 +0100
commit824b6de96ddfe791a0013d96a84ad49de8e04d38 (patch)
tree611807de8115ff1c6ca9fc0ac4c36dfa885f6c58 /meta-oe/recipes-devtools/mpich
parentfca56b63f267b5bba3f76b59eac4c5b397e86ceb (diff)
downloadmeta-openembedded-contrib-824b6de96ddfe791a0013d96a84ad49de8e04d38.tar.gz
Add mpich support
This patch add mpich support to yocto in order to run MPI framework on embedded systems. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Victor Rodriguez <victor.rodriguez.bahena@intel.com> Signed-off-by: Alexandru.Vaduva <Alexandru.Vaduva@enea.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/mpich')
-rw-r--r--meta-oe/recipes-devtools/mpich/mpich_3.1.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/mpich/mpich_3.1.1.bb b/meta-oe/recipes-devtools/mpich/mpich_3.1.1.bb
new file mode 100644
index 0000000000..2f4226ea9e
--- /dev/null
+++ b/meta-oe/recipes-devtools/mpich/mpich_3.1.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Message Passing Interface(MPI) implementation"
+HOMEPAGE = "http://git.mpich.org/mpich.git/"
+SECTION = "devel"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=2106f0435056f3dd9349747a766e5816"
+
+SRC_URI = "http://www.mpich.org/static/downloads/${PV}/mpich-${PV}.tar.gz"
+SRC_URI[md5sum] = "40dc408b1e03cc36d80209baaa2d32b7"
+SRC_URI[sha256sum] = "455ccfaf4ec724d2cf5d8bff1f3d26a958ad196121e7ea26504fd3018757652d"
+
+RDEPENDS_${PN} += "bash perl tcsh"
+S = "${WORKDIR}/${PN}-${PV}"
+
+EXTRA_OECONF = "--enable-debuginfo \
+ --enable-fast \
+ --enable-shared \
+ --disable-f77 \
+ --disable-fc \
+ --disable-fortran \
+ --disable-cxx"
+
+inherit autotools-brokensep gettext
+
+do_configure_prepend() {
+ autoreconf --verbose --install --force -I . -I confdb/ -I maint/
+ oe_runconf
+ exit
+}