aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/mercurial
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-26 12:53:33 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-27 20:07:10 -0800
commit8b21e77502055c8078132cdac57a4736108b3a5a (patch)
tree4fbd10b53a1ba3b0b81e899746dbf441c069dabe /meta-oe/recipes-devtools/mercurial
parentb18be1a48d4a0e6ddc220f0ecea074059cf2ad9f (diff)
downloadmeta-openembedded-contrib-8b21e77502055c8078132cdac57a4736108b3a5a.tar.gz
mercurial: Upgrade to 5.2 and switch to py3
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/mercurial')
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial_5.2.bb (renamed from meta-oe/recipes-devtools/mercurial/mercurial_4.6.1.bb)18
1 files changed, 11 insertions, 7 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial_4.6.1.bb b/meta-oe/recipes-devtools/mercurial/mercurial_5.2.bb
index 13710aaea3..0fec4d1f17 100644
--- a/meta-oe/recipes-devtools/mercurial/mercurial_4.6.1.bb
+++ b/meta-oe/recipes-devtools/mercurial/mercurial_5.2.bb
@@ -3,29 +3,33 @@ HOMEPAGE = "http://mercurial.selenic.com/"
SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "python python-native"
-DEPENDS_class-native = "python-native"
-RDEPENDS_${PN} = "python python-modules"
-inherit python-dir
+DEPENDS = "python3 python3-native"
+RDEPENDS_${PN} = "python3 python3-modules"
+
+inherit python3native
SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz"
-SRC_URI[md5sum] = "f9b2e4a3b5901ef744fa3abe4196e97e"
-SRC_URI[sha256sum] = "89fa8ecbc8aa6e48e98f9803a1683ba91367124295dba2407b28c34ca621108d"
+SRC_URI[md5sum] = "9ba9d59157c002db8d8cab680de08eb5"
+SRC_URI[sha256sum] = "ff030e923f03ee15c91191996fcb099bfcfa60c7df263be227f67b6a65d36194"
S = "${WORKDIR}/mercurial-${PV}"
BBCLASSEXTEND = "native"
+export LDSHARED="${CCLD} -shared"
+
EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
PREFIX=${prefix}"
do_configure_append () {
- sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile
+ sed -i -e 's:PYTHON?=python:PYTHON=python3:g' ${S}/Makefile
}
do_install () {
oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
+ sed -i -e 's:${STAGING_BINDIR_NATIVE}/python3-native/python3:${USRBINPATH}/env python3:g' ${D}${bindir}/hg
}
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
+