aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/libubox
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2015-10-01 17:31:36 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:28:14 +0200
commit8dacaa70ba0f4b17a48278801e6c90eb71bb7010 (patch)
treeae23a364378a49e368c6a70aded07ae276ba71ae /meta-oe/recipes-devtools/libubox
parentdcba860726c64e9bfa7ed06d8bf141a562a97070 (diff)
downloadmeta-openembedded-contrib-8dacaa70ba0f4b17a48278801e6c90eb71bb7010.tar.gz
meta-oe: recipes-devtools: add libubox recipe
libubox contains C utility functions used by OpenWrt projects Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/libubox')
-rw-r--r--meta-oe/recipes-devtools/libubox/libubox/0001-version-libraries.patch28
-rw-r--r--meta-oe/recipes-devtools/libubox/libubox_git.bb28
2 files changed, 56 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/libubox/libubox/0001-version-libraries.patch b/meta-oe/recipes-devtools/libubox/libubox/0001-version-libraries.patch
new file mode 100644
index 0000000000..02117fa8d6
--- /dev/null
+++ b/meta-oe/recipes-devtools/libubox/libubox/0001-version-libraries.patch
@@ -0,0 +1,28 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 57804cf..1aa7f27 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -18,6 +18,7 @@ ENDIF()
+ SET(SOURCES avl.c avl-cmp.c blob.c blobmsg.c uloop.c usock.c ustream.c ustream-fd.c vlist.c utils.c safe_list.c runqueue.c md5.c kvlist.c ulog.c base64.c)
+
+ ADD_LIBRARY(ubox SHARED ${SOURCES})
++SET_TARGET_PROPERTIES(ubox PROPERTIES VERSION 1.0.1 SOVERSION 1)
+ ADD_LIBRARY(ubox-static STATIC ${SOURCES})
+ SET_TARGET_PROPERTIES(ubox-static PROPERTIES OUTPUT_NAME ubox)
+
+@@ -46,6 +47,7 @@ find_library(json NAMES json-c)
+ IF(EXISTS ${json})
+ ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
+ TARGET_LINK_LIBRARIES(blobmsg_json ubox ${json})
++ SET_TARGET_PROPERTIES(blobmsg_json PROPERTIES VERSION 1.0.1 SOVERSION 1)
+
+ ADD_LIBRARY(blobmsg_json-static STATIC blobmsg_json.c)
+ SET_TARGET_PROPERTIES(blobmsg_json-static
+@@ -55,6 +57,7 @@ IF(EXISTS ${json})
+ TARGET_LINK_LIBRARIES(jshn blobmsg_json ${json})
+
+ ADD_LIBRARY(json_script SHARED json_script.c)
++ SET_TARGET_PROPERTIES(json_script PROPERTIES VERSION 1.0.1 SOVERSION 1)
+ TARGET_LINK_LIBRARIES(json_script ubox)
+
+ INSTALL(TARGETS blobmsg_json blobmsg_json-static jshn json_script
diff --git a/meta-oe/recipes-devtools/libubox/libubox_git.bb b/meta-oe/recipes-devtools/libubox/libubox_git.bb
new file mode 100644
index 0000000000..3e886b766d
--- /dev/null
+++ b/meta-oe/recipes-devtools/libubox/libubox_git.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "C utility functions for OpenWrt"
+SECTION = "libs"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "\
+ file://avl.c;endline=39;md5=00810155fed3d604816ec5814523d60a \
+ file://avl-cmp.c;endline=15;md5=1603e6094b432a5f3f320877a06f41b5 \
+ file://base64.c;endline=61;md5=51fdff010d45b0086ac0a6e035693dc0 \
+ file://blobmsg.c;endline=15;md5=7ed64c1570e8c9b46c4fc6fbd16c489e \
+ file://list.h;endline=28;md5=2d5f5475fbd0f08741354c5a99c2e983 \
+ file://md5.h;endline=39;md5=048bf9f68963c207a0c2b3a94c9d2aaa \
+ file://md5.c;endline=51;md5=0a448eea0bcbc89e3c7e6608f2d119a0 \
+ file://usock.h;endline=18;md5=f0dfdc8de858e66d66d74036611bba14 \
+"
+
+SRC_URI = "\
+ git://git.openwrt.org/project/libubox.git \
+ file://0001-version-libraries.patch \
+"
+
+SRCREV = "136a5196266d03d537f822c4e67d2fde2ed59505"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+DEPENDS = "json-c"
+
+EXTRA_OECMAKE = "-DBUILD_EXAMPLES=OFF -DBUILD_LUA=OFF"