aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-09-20 10:12:50 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:47 +0000
commit7addfd42f684cacf35182ae25f016e58b5585142 (patch)
treeb4decd989703d63385c3946656c5f9ce4617ef87 /meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.3.bb
parent98f96aa15e3035ec4fda9225f4fc673633288856 (diff)
downloadmeta-openembedded-contrib-7addfd42f684cacf35182ae25f016e58b5585142.tar.gz
jsoncpp: update to version 1.8.3
Checksum update for copyright year Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.3.bb')
-rw-r--r--meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.3.bb b/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.3.bb
new file mode 100644
index 0000000000..b7a02ef159
--- /dev/null
+++ b/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.3.bb
@@ -0,0 +1,21 @@
+SUMMARY = "JSON C++ lib used to read and write json file."
+DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \
+ and writer in C++. JSON (JavaScript Object Notation) is a \
+ lightweight data-interchange format. It is easy for humans to \
+ read and write. It is easy for machines to parse and generate."
+
+HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
+
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa2a23dd1dc6c139f35105379d76df2b"
+
+SRCREV = "2de18021fcb11370e9b5a1fbe7dcfd673533a134"
+SRC_URI = "git://github.com/open-source-parsers/jsoncpp"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DJSONCPP_WITH_TESTS=OFF"