aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-23 15:40:35 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-23 15:43:06 -0800
commit3e6f82dd54b296072d725f5691204618d60a2666 (patch)
treea1151e330ca116c459a251098d203407a9acf2cf /meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb
parent0948ba8e496c3ad2e16e4906574fc120db813182 (diff)
downloadmeta-openembedded-contrib-3e6f82dd54b296072d725f5691204618d60a2666.tar.gz
heaptrack: Fix build on musl
Improve upon summary and description fields Add PV to the recipe Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Sinan Kaya <okaya@kernel.org>
Diffstat (limited to 'meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb')
-rw-r--r--meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb b/meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb
new file mode 100644
index 0000000000..14d3983ca6
--- /dev/null
+++ b/meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Heap memory profiler for Linux"
+DESCRIPTION = "Heaptrack traces all memory allocations and annotates these \
+events with stack traces. Dedicated analysis tools then allow you to interpret \
+the heap memory profile to find hotspots to reduce memory, leaks, allocation \
+hotspots and temporary allocations"
+HOMEPAGE = "https://phabricator.kde.org/source/heaptrack/"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "zlib boost libunwind elfutils"
+
+SRC_URI = "git://github.com/KDE/heaptrack.git;protocol=https \
+ file://0001-libheaptrack-Replace-__pid_t-with-pid_t.patch \
+ file://0002-heaptrack_inject-Include-dlfcn.h-for-dlopen-dlclose.patch \
+ file://0003-heaptrack_preload-Make-noexcept-attribute-conditiona.patch \
+ file://0004-backtrace-Always-include-stdint.h.patch \
+ "
+
+SRCREV = "bc9e3744bcc47de978673d1e382f4125a1ab5fa8"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DHEAPTRACK_BUILD_GUI=OFF"
+
+BBCLASSEXTEND = "native nativesdk"