aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/debootstrap
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2021-06-02 13:46:00 +0800
committerKhem Raj <raj.khem@gmail.com>2021-06-02 11:28:35 -0700
commit06d27606e8b7125396d333212a8dd04a529bbaa8 (patch)
tree1503d73d23480d08f17094451bdfbb3a5d74b709 /meta-oe/recipes-devtools/debootstrap
parent2449e5f07a39ae9c0a0f1d931d8ef2b71de3e193 (diff)
downloadmeta-openembedded-contrib-06d27606e8b7125396d333212a8dd04a529bbaa8.tar.gz
debootstrap: fix runtime failure on nativesdk
While calling debootstrap in sdk, if host does not install dpkg package, the full path calling will fail Do not hardcode the full path of dpkg, then the sdk's dpkg will be used. In Yocto, for debootstrap, only dpkg is used, so the fix do not take care of other utilities (such as /usr/bin/udpkg) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/debootstrap')
-rw-r--r--meta-oe/recipes-devtools/debootstrap/debootstrap/0001-do-not-hardcode-the-full-path-of-dpkg.patch33
-rw-r--r--meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.124.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/debootstrap/debootstrap/0001-do-not-hardcode-the-full-path-of-dpkg.patch b/meta-oe/recipes-devtools/debootstrap/debootstrap/0001-do-not-hardcode-the-full-path-of-dpkg.patch
new file mode 100644
index 0000000000..2a5f233165
--- /dev/null
+++ b/meta-oe/recipes-devtools/debootstrap/debootstrap/0001-do-not-hardcode-the-full-path-of-dpkg.patch
@@ -0,0 +1,33 @@
+From e735fb23f46f0c3c7a1144ba6b4050bfc0015a05 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Wed, 2 Jun 2021 13:34:35 +0800
+Subject: [PATCH] do not hardcode the full path of dpkg
+
+While calling debootstrap in sdk, if host does not install dpkg package,
+the full path calling will fail
+
+Do not hardcode the full path of dpkg, then then sdk's dpkg will be used.
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ debootstrap | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/debootstrap b/debootstrap
+index a3cf3af..5e96c3e 100755
+--- a/debootstrap
++++ b/debootstrap
+@@ -538,7 +538,7 @@ fi
+
+ if in_path dpkg && \
+ dpkg --print-architecture >/dev/null 2>&1; then
+- HOST_ARCH=$(/usr/bin/dpkg --print-architecture)
++ HOST_ARCH=$(dpkg --print-architecture)
+ elif in_path udpkg && \
+ udpkg --print-architecture >/dev/null 2>&1; then
+ HOST_ARCH=$(/usr/bin/udpkg --print-architecture)
+--
+2.27.0
+
diff --git a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.124.bb b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.124.bb
index 300c98f91b..4fc59adfbe 100644
--- a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.124.bb
+++ b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.124.bb
@@ -8,6 +8,7 @@ SRC_URI = "\
http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_${PV}.tar.gz \
file://0001-support-to-override-usr-sbin-and-usr-share.patch \
file://0002-support-to-override-usr-bin-arch-test.patch \
+ file://0001-do-not-hardcode-the-full-path-of-dpkg.patch \
"
SRC_URI[md5sum] = "8a5e97f60236c3a63f715c056a5f0e29"