aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloud9
diff options
context:
space:
mode:
authorJason Kridner <jdk@ti.com>2011-10-19 18:08:38 -0400
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-21 14:57:30 +0200
commit36423031ae2cc2157232f3bec8f5c9fa53ef215d (patch)
tree2c111897f54947caf4dfda329a1f95dcc6f8121d /meta-oe/recipes-devtools/cloud9
parent949ec2d7319205a3a0366d18291a92541dfa038c (diff)
downloadmeta-openembedded-contrib-36423031ae2cc2157232f3bec8f5c9fa53ef215d.tar.gz
Cloud9: incremental submodule and build fixes
Signed-off-by: Jason Kridner <jdk@ti.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cloud9')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9/0001-remove-x86-specific-compiler-flags.patch25
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb89
2 files changed, 79 insertions, 35 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9/0001-remove-x86-specific-compiler-flags.patch b/meta-oe/recipes-devtools/cloud9/cloud9/0001-remove-x86-specific-compiler-flags.patch
new file mode 100644
index 0000000000..099507dfb8
--- /dev/null
+++ b/meta-oe/recipes-devtools/cloud9/cloud9/0001-remove-x86-specific-compiler-flags.patch
@@ -0,0 +1,25 @@
+From 2e36a24997feb30ea8325eca5575e2e968909a5f Mon Sep 17 00:00:00 2001
+From: Jason Kridner <jdk@ti.com>
+Date: Thu, 20 Oct 2011 14:45:34 -0400
+Subject: [PATCH] remove x86-specific compiler flags
+
+---
+ wscript | 2 --
+ 1 files changed, 0 insertions(+), 2 deletions(-)
+
+diff --git a/../o3/wscript b/../o3/wscript
+index 6e21bee..607e1c3 100644
+--- a/../o3/wscript
++++ b/../o3/wscript
+@@ -9,8 +9,6 @@ def configure(conf):
+ conf.check_tool('compiler_cxx')
+ conf.check_tool('node_addon')
+ conf.add_os_flags('LDFLAGS','LINKFLAGS')
+- conf.env.append_value('CCFLAGS', ['-O3', '-msse2', '-ffast-math'])
+- conf.env.append_value('CXXFLAGS', ['-O3', '-msse2', '-ffast-math'])
+
+ def build(bld):
+ obj = bld.new_task_gen('cxx', 'shlib', 'node_addon')
+--
+1.7.4.1
+
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
index 05e5bebbef..b06e59260f 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
@@ -3,79 +3,98 @@ HOMEPAGE = "http://c9.io"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
-PR = "r4"
+DEPENDS = "nodejs-native"
+
+PR = "r5"
SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
- git://github.com/ajaxorg/connect.git;destsuffix=git/support/connect;name=connect \
+ git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \
+ git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \
+ git://github.com/ajaxorg/ace.wiki.git;destsuffix=git/support/ace/doc/wiki;name=acewiki \
+ git://github.com/ajaxorg/cockpit.git;destsuffix=git/support/ace/support/cockpit;name=cockpit \
+ git://github.com/ajaxorg/dryice.git;destsuffix=git/support/ace/support/dryice;name=dryice \
+ git://github.com/ajaxorg/pilot.git;destsuffix=git/support/ace/support/pilot;name=pilot \
+ git://github.com/ajaxorg/apf.git;destsuffix=git/support/apf;name=apf \
git://github.com/ajaxorg/async.js.git;destsuffix=git/support/asyncjs;name=asyncjs \
+ git://github.com/ajaxorg/connect.git;destsuffix=git/support/connect;name=connect \
+ git://github.com/jashkenas/coffee-script.git;destsuffix=git/support/connect/support/coffee-script;name=coffee-script \
+ git://github.com/visionmedia/expresso.git;destsuffix=git/support/connect/support/expresso;name=expresso \
+ git://github.com/visionmedia/node-jscoverage.git;destsuffix=git/support/connect/support/expresso/deps/jscoverage;name=jscoverage \
+ git://github.com/cloudhead/less.js.git;destsuffix=git/support/connect/support/less;name=less \
+ git://github.com/visionmedia/sass.js.git;destsuffix=git/support/connect/support/sass;name=sass \
git://github.com/ajaxorg/jsDAV.git;destsuffix=git/support/jsdav;name=jsdav \
+ git://github.com/fjakobs/async.js.git;destsuffix=git/support/jsdav/support/async.js;name=async-js \
+ git://github.com/felixge/node-formidable.git;destsuffix=git/support/jsdav/support/formidable;name=formidable \
+ git://github.com/ajaxorg/jsftp.git;destsuffix=git/support/jsdav/support/jsftp;name=jsftp \
+ git://github.com/Gozala/streamer.git;destsuffix=git/support/jsdav/support/jsftp/support/streamer;name=streamer \
+ git://github.com/ajaxorg/node-sftp.git;destsuffix=git/support/jsdav/support/node-sftp;name=sftp \
git://github.com/ajaxorg/lib-v8debug.git;destsuffix=git/support/lib-v8debug;name=lib-v8debug \
- git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \
- git://github.com/ajaxorg/apf.git;destsuffix=git/support/apf;name=apf \
- git://github.com/ajaxorg/node-builds-v4.git;destsuffix=git/support/node-builds-v4;name=node-builds-v4 \
- git://github.com/ajaxorg/gnu-builds.git;destsuffix=git/support/gnu-builds;name=gnu-builds \
git://github.com/ajaxorg/socket.io.git;destsuffix=git/support/socket.io;name=socketio \
git://github.com/ajaxorg/socket.io-client.git;destsuffix=git/support/socket.io-client;name=socketio-client \
- git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglifyjs \
+ git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglify-js \
+ file://0001-remove-x86-specific-compiler-flags.patch \
file://cloud9.service \
"
-SRCREV_cloud9ide = "593948c9aaded845cb8f3ced49ef41428e351264"
-SRCREV_connect = "3d1d77a113fa2f18020f562832dca3d4c2d717a2"
+SRCREV_cloud9ide = "f2bb59777c0c1fa9c82e8307094e3595e2c9db0b"
+SRCREV_o3 = "806422e9fd12251d4a3bb408fd86773867d7e09a"
+SRCREV_ace = "9ec72ff319c06c4a1f93dae3157021eefbac338d"
+SRCREV_acewiki = "cc5ccde4565f7b21c81345f47e941e011e94b810"
+SRCREV_cockpit = "33f02ab3af5d755c98b3c58309ac2c62fc6de736"
+SRCREV_dryice = "375d9a339646d70846ad40eddaad406198dd9d40"
+SRCREV_pilot = "48ddaa841476ddf9210ccbb2b310952db8212084"
+SRCREV_apf = "6bdac74916fe85a6f63eb8561667628b5ede659c"
SRCREV_asyncjs = "d36ead408e2959b1e99572114ef3a1b6a48c1072"
+SRCREV_connect = "6bec95b51f2286b942bc7f340d62d816bcdc13d4"
+SRCREV_coffee-script = "a53c104db16d3ac9d13cf9f16834edec250b9749"
+SRCREV_expresso = "7f10ab7fa655299b4e2f519065b0495e6ac34ef2"
+SRCREV_jscoverage = "0d4608a6b4275b020ba665389aa75897d5d4a584"
+SRCREV_less = "a2807288008587b95c6c2f8ba5cac16f1bcab98f"
+SRCREV_sass = "4dfd4c699e7a8baf226215ab044854c4507f4420"
SRCREV_jsdav = "f1d1f691fdb521701c1c06d158d213575e4e4e5e"
+SRCREV_async-js = "92fb710a70efd3cdc2376ebfba71a7fb3a4f1651"
+SRCREV_formidable = "0cba820cabc23250d47754e57d9f61cc73d12f2a"
+SRCREV_jsftp = "2343ab78e61dfe35312d4adabbc6ee36e0afd122"
+SRCREV_streamer = "1a7f75d4065819171ac91a09974199b932dbe17d"
+SRCREV_sftp = "a0539345134970d7535a19cb2608e3d1bc119d71"
SRCREV_lib-v8debug = "29b20d01e6854da2173e1665ea141dab6b5a8104"
-SRCREV_ace = "d85acd115e88e4461a04fafc6a93a801aeb057ec"
-SRCREV_apf = "a7e0daa29573f319f22be5a6cfa275243502604b"
-SRCREV_node-builds-v4 = "2e3ac47b7b8d506147feb08372cc36b988b6195a"
-SRCREV_gnu-builds = "9ff133d95f9a41d749fe16220d81517dad9a2db3"
SRCREV_socketio = "8f82b1e4e1076a3092fed77e0dc9379425f59b9d"
SRCREV_socketio-client = "7b5335d1ed88564928a5d00d8a750ff9f9c627a5"
-SRCREV_uglifyjs = "941c845c4a01e4e47a158458fe846eb36d0828ad"
+SRCREV_uglify-js = "941c845c4a01e4e47a158458fe846eb36d0828ad"
SRCREV_FORMAT = "cloud9ide"
S = "${WORKDIR}/git"
-# Most of cloud9 is in git submodules that still need to be fetched.
-do_configure_prepend () {
- git submodule update --init --recursive
+do_configure () {
+ cd ${WORKDIR}/o3
+ node-waf configure
}
-# There's nothing left to be compiled at this time.
-# node-o3-xml is the only compiled code module in here.
-# The repository has binaries for:
-# Linux ARM armv7
-# Linux x86 32/64-bit
-# Sun Solaris 32-bit
-# Mac x86 32/64-bit
-# Windows x86 32-bit
do_compile () {
-:
+ cd ${WORKDIR}/o3
+ node tools/gluegen.js
+ node-waf
}
do_install () {
install -m 0755 -d ${D}/usr/share/cloud9 ${D}${bindir} ${D}/var/lib/cloud9
rsync -r --exclude=".*" ${S}/* ${D}/usr/share/cloud9
- for i in cygwin darwin linux32 linux64 sunos ; do
- rm -f ${D}/usr/share/cloud9/support/node-builds-v4/*$i*
- rm -f ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/*$i*
- rm -f ${D}//usr/share/cloud9/support/gnu-builds/*$i*
- done
-
touch ${D}${bindir}/cloud9
echo "#!/bin/sh" > ${D}${bindir}/cloud9
echo "node /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9
chmod 0755 ${D}${bindir}/cloud9
- install -d ${D}${base_libdir}/systemd/system
+ install -m 0755 -d ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml/lib
+ install -m 0644 ${WORKDIR}/o3/modules/o3.js ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml/lib/o3-xml.js
+ install -m 0755 ${WORKDIR}/o3/build/default/o3.node ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml/lib/o3.node
+
+ install -m 0755 -d ${D}${base_libdir}/systemd/system
install -m 0644 ${WORKDIR}/*.service ${D}${base_libdir}/systemd/system/
}
-FILES_${PN}-dbg += "/usr/share/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug"
-
FILES_${PN} += "${base_libdir}/systemd/system"
RDEPENDS_${PN} = "nodejs gzip"