aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloud9
diff options
context:
space:
mode:
authorJason Kridner <jdk@ti.com>2011-10-06 06:21:51 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-07 20:24:22 +0200
commite57ec76108139fec1f8c4ee12711a9519ebb0902 (patch)
treed2d0e3b06b8f80da004dd946fa8324b0d62e4af1 /meta-oe/recipes-devtools/cloud9
parentd7c12fd07498af06f4c03182c838528e765e4721 (diff)
downloadmeta-openembedded-contrib-e57ec76108139fec1f8c4ee12711a9519ebb0902.tar.gz
cloud9: created
Cloud9 is a web-browser based IDE running on node.js. This application should support multiple architectures as long as they have node.js and a build of node-o3-xml that is dropped into this system. Currently, that includes x86 32/64-bit and ARM armv7. Ideally, that library would be added separately as a system-dependent portion, because everything else should be ISA independent. [ small DEPENDS fixes added by koen ] Signed-off-by: Jason Kridner <jdk@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/cloud9')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
new file mode 100644
index 0000000000..b6d2da085d
--- /dev/null
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Meet Cloud9, development-as-a-service for Javascripters and other developers"
+HOMEPAGE = "http://c9.io"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
+
+SRC_URI = "git://github.com/jadonk/cloud9.git;protocol=git \
+"
+
+SRCREV = "08bae1d1cc2ba9f7f883a25afd07f0339a82fa8b"
+S = "${WORKDIR}/git"
+
+# Most of cloud9 is in git submodules that still need to be fetched.
+do_configure_prepend () {
+ git submodule update --init --recursive
+}
+
+# There's nothing left to be compiled at this time.
+# node-o3-xml is the only compiled code module in here.
+# The repository has binaries for:
+# Linux ARM armv7
+# Linux x86 32/64-bit
+# Sun Solaris 32-bit
+# Mac x86 32/64-bit
+# Windows x86 32-bit
+do_compile () {
+:
+}
+
+do_install () {
+ install -m 0755 -d ${D}/usr/share/cloud9 ${D}${bindir} ${D}/var/lib/cloud9
+ rsync -r --exclude=".*" ${S}/* ${D}/usr/share/cloud9
+ touch ${D}${bindir}/cloud9
+ echo "#!/bin/sh" > ${D}${bindir}/cloud9
+ echo "node /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9
+ chmod 0755 ${D}${bindir}/cloud9
+}
+
+RDEPENDS_${PN} = "nodejs"
+