aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloud9
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-07 23:13:18 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-07 23:13:18 +0200
commitc961f6218042399c386e776da75a401ee9989463 (patch)
treee0eca70ba450504a8ffb8e5cf50e45ae990a21f8 /meta-oe/recipes-devtools/cloud9
parente57ec76108139fec1f8c4ee12711a9519ebb0902 (diff)
downloadmeta-openembedded-contrib-c961f6218042399c386e776da75a401ee9989463.tar.gz
cloud9: fix packaging
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/cloud9')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
index b6d2da085d..1235d24f6e 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
@@ -3,8 +3,9 @@ HOMEPAGE = "http://c9.io"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
-SRC_URI = "git://github.com/jadonk/cloud9.git;protocol=git \
-"
+PR = "r1"
+
+SRC_URI = "git://github.com/jadonk/cloud9.git;protocol=git"
SRCREV = "08bae1d1cc2ba9f7f883a25afd07f0339a82fa8b"
S = "${WORKDIR}/git"
@@ -29,11 +30,19 @@ do_compile () {
do_install () {
install -m 0755 -d ${D}/usr/share/cloud9 ${D}${bindir} ${D}/var/lib/cloud9
rsync -r --exclude=".*" ${S}/* ${D}/usr/share/cloud9
+
+ for i in cygwin darwin linux32 linux64 sunos ; do
+ rm -f ${D}/usr/share/cloud9/support/node-builds-v4/*$i*
+ rm -f ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/*$i*
+ rm -f ${D}//usr/share/cloud9/support/gnu-builds/*$i*
+ done
+
touch ${D}${bindir}/cloud9
echo "#!/bin/sh" > ${D}${bindir}/cloud9
echo "node /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9
chmod 0755 ${D}${bindir}/cloud9
}
+FILES_${PN}-dbg += "/usr/share/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug"
RDEPENDS_${PN} = "nodejs"