aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloc/cloc_1.98.bb
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2023-11-16 19:55:27 +0300
committerKhem Raj <raj.khem@gmail.com>2023-11-17 11:38:25 -0800
commit1292ec8a03dd14bedd95fb3f1100212a81d475fe (patch)
tree6769b1174e8be9f0063eaa8169776cee8b92bed5 /meta-oe/recipes-devtools/cloc/cloc_1.98.bb
parentdbee6afc11686501e9f9866d623d24e3ff440006 (diff)
downloadmeta-openembedded-contrib-1292ec8a03dd14bedd95fb3f1100212a81d475fe.tar.gz
cloc: upgrade 1.94 -> 1.98
Changelog: - New Languages: Cairo, Carbon, Circom, Containerfile, HolyC, kvlang, Nunjucks, OpenSCAD, P4, Pest, Pony, TEAL, WGSL - New switch --diff-list-files to run diff given two list files - Handle comments embedded in OCaml strings - Write empty JSON and XML structures if the inputs yield zero counts - Support for long paths on Windows - Better support for building and running Docker image on Windows - Better output file names when running with --count-and-diff and --out; - Resolve internal file handle conflict when running --diff with --sdir or --categorized - New Languages: Asymptote, CoCoA 5, Constraint Grammar, Hare, Jai, Linker Script, NetLogo, Typst - Added .editorconfig as an INI extension. - Added .cppm, .ixx, .ccm, .cxxm, .c++m as C++ extensions. - Improved handling of trailing slash with --match-d - --exclude-list-file with --git now works as expected. - --not-match-d, --not-match-f can now be repeated. - --quiet mode is now enabled when STDOUT is not a terminal. This makes for cleaner output when piping to other programs. - New switch --include-content=regex to only count files whose content matches the given regex. - New switch --only-count-files to only count files. Counts for blank, comment, and code lines will be zero. - --no-recurse now works on Windows - Improved exclusion of autogenerated files on Windows. - Improved handling of path separators with git in PowerShell. - Resolve nondeterministic --diff output. - --hide-rate supports all output file types - Fixed --diff-list-file with unknown listed file. - Fixed parsing of verbose option in the cloc configuration file. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cloc/cloc_1.98.bb')
-rw-r--r--meta-oe/recipes-devtools/cloc/cloc_1.98.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cloc/cloc_1.98.bb b/meta-oe/recipes-devtools/cloc/cloc_1.98.bb
new file mode 100644
index 0000000000..ea5f00669f
--- /dev/null
+++ b/meta-oe/recipes-devtools/cloc/cloc_1.98.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Count blank lines, comment lines, and physical lines of source code \
+in many programming languages."
+
+LICENSE="GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
+
+SRC_URI = "https://github.com/AlDanial/cloc/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI[sha256sum] = "5fe0b159eb75718df7308a4f61470eaddf82170733929999e37a3fbb4651cf8a"
+
+UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc
+}
+
+RDEPENDS:${PN} = "perl perl-modules"