aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cjson
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-04-26 10:55:27 +0800
committerKhem Raj <raj.khem@gmail.com>2020-04-26 23:10:57 -0700
commit13174e92a9c5e5ecc0b3e991721a4ed292f6578a (patch)
tree1407b35cfeadaeba2f69408a1314c543f6fccd0b /meta-oe/recipes-devtools/cjson
parentb0345e3fe439ebfeea84edaf26c19b056d557400 (diff)
downloadmeta-openembedded-contrib-13174e92a9c5e5ecc0b3e991721a4ed292f6578a.tar.gz
cjson: add recipe for v1.7.13
cJSON aims to be the dumbest possible parser that you can get your job done with. It's a single file of C, and a single header file. Homepage: https://github.com/DaveGamble/cJSON Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cjson')
-rw-r--r--meta-oe/recipes-devtools/cjson/cjson_1.7.13.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cjson/cjson_1.7.13.bb b/meta-oe/recipes-devtools/cjson/cjson_1.7.13.bb
new file mode 100644
index 0000000000..e6174821ff
--- /dev/null
+++ b/meta-oe/recipes-devtools/cjson/cjson_1.7.13.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Ultralightweight JSON parser in ANSI C"
+AUTHOR = "Dave Gamble"
+HOMEPAGE = "https://github.com/DaveGamble/cJSON"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=218947f77e8cb8e2fa02918dc41c50d0"
+
+SRC_URI = "git://github.com/DaveGamble/cJSON.git"
+SRCREV = "39853e5148dad8dc5d32ea2b00943cf4a0c6f120"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += "\
+ -DENABLE_CJSON_UTILS=On \
+ -DENABLE_CUSTOM_COMPILER_FLAGS=OFF \
+ -DBUILD_SHARED_AND_STATIC_LIBS=On \
+"
+
+BBCLASSEXTEND = "native nativesdk"