aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb
diff options
context:
space:
mode:
authormcrapet <Matthieu.Crapet@ingenico.com>2015-06-03 11:12:36 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-06-08 14:15:24 +0200
commit7db802aa7f1440e78c179984cf621bdeea7d6264 (patch)
tree00b33d66841ab9f1c888e4926ceb70af39255414 /meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb
parent4bcddcaccb5950ec0208e2a25eb05c7016e25db4 (diff)
downloadmeta-openembedded-contrib-7db802aa7f1440e78c179984cf621bdeea7d6264.tar.gz
cgdb: update to 0.6.8
Changes: - add missing build dependency to flex-native - GDB is a runtime dependency, set it so - use CACHED_CONFIGUREVARS to drop patch - use ${BP} - add missing DESCRIPTION - no help2man build dependency (cgdb.1 man page is not generated) Cc: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb')
-rw-r--r--meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb b/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb
new file mode 100644
index 0000000000..74019fb622
--- /dev/null
+++ b/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb
@@ -0,0 +1,21 @@
+SUMMARY = "curses-based interface to GDB"
+DESCRIPTION = "cgdb is a lightweight curses (terminal-based) interface to the GNU Debugger (GDB)."
+HOMEPAGE = "http://cgdb.github.io/"
+SECTION = "devel"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "flex-native readline ncurses"
+
+inherit autotools
+
+SRC_URI = "http://cgdb.me/files/${BP}.tar.gz \
+ file://remove-help2man.patch"
+SRC_URI[md5sum] = "7bd38c79bf4d794d239928fef401fca3"
+SRC_URI[sha256sum] = "be203e29be295097439ab67efe3dc8261f742c55ff3647718d67d52891f4cf41"
+
+CACHED_CONFIGUREVARS = "ac_cv_file__dev_ptmx=yes ac_cv_rl_version=6.2"
+EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR} \
+ --with-ncurses=${STAGING_LIBDIR}"
+
+RDEPENDS_${PN} = "gdb"