aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/breakpad
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-05-05 14:11:12 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-16 21:09:05 +0200
commite836f8f936f1a39e8b29c08a5979919d9e04cbde (patch)
tree884b28f2d2fe92cc41677f6176aca2e776245d17 /meta-oe/recipes-devtools/breakpad
parentb3b6743e0e2cc21e86e33efb06bb68881c0420b0 (diff)
downloadmeta-openembedded-contrib-e836f8f936f1a39e8b29c08a5979919d9e04cbde.tar.gz
gegl, crash, libsecret, mpg123, tinymembench, gammu, mosh, llvm3.3, breakpad, php, mozjs, libopus: disable thumb where it fails for qemuarm
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/breakpad')
-rw-r--r--meta-oe/recipes-devtools/breakpad/breakpad_svn.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad_svn.bb b/meta-oe/recipes-devtools/breakpad/breakpad_svn.bb
index fcebccfc72..7ada3a3b2e 100644
--- a/meta-oe/recipes-devtools/breakpad/breakpad_svn.bb
+++ b/meta-oe/recipes-devtools/breakpad/breakpad_svn.bb
@@ -76,3 +76,14 @@ breakpad_populate_sysroot() {
sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib
}
+# Fails to build with thumb-1 (qemuarm)
+#| {standard input}: Assembler messages:
+#| {standard input}:2178: Error: selected processor does not support Thumb mode `it ne'
+#| {standard input}:2179: Error: Thumb does not support conditional execution
+#| {standard input}:2180: Error: selected processor does not support Thumb mode `it eq'
+#| {standard input}:2181: Error: Thumb does not support conditional execution
+#| {standard input}:2183: Error: lo register required -- `str ip,[r1,#-4]!'
+#| {standard input}:2184: Error: Thumb does not support this addressing mode -- `str r6,[r1,#-4]!'
+#| {standard input}:2191: Error: lo register required -- `ldr pc,[sp]'
+#| make: *** [src/client/linux/handler/exception_handler.o] Error 1
+ARM_INSTRUCTION_SET = "arm"