aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-13 22:24:56 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-13 22:26:18 -0700
commit9af3510170137070cb269e6cf0399ac43ad8bece (patch)
tree0a6fce361a1baaf6fc8284e64e9b850cf1c49058 /meta-oe/recipes-dbs
parentef03326d31360abdfa3e4a34eb00b328a76de12c (diff)
downloadmeta-openembedded-contrib-9af3510170137070cb269e6cf0399ac43ad8bece.tar.gz
lmdb: Pass CFLAGS to Makefile
This ensures that __FILE__ macros is expanded correctly without buildpaths Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r--meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb b/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb
index a76d388d70..35242bedb6 100644
--- a/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb
+++ b/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb
@@ -21,11 +21,11 @@ inherit ptest
S = "${WORKDIR}/git/libraries/liblmdb"
do_compile() {
- oe_runmake CC="${CC}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}"
+ oe_runmake CC="${CC}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}" XCFLAGS="${CFLAGS}"
}
do_install() {
- oe_runmake CC="${CC}" DESTDIR="${D}" prefix="${prefix}" libprefix="${libdir}" manprefix="${mandir}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}" install
+ oe_runmake CC="${CC}" DESTDIR="${D}" prefix="${prefix}" libprefix="${libdir}" manprefix="${mandir}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}" XCFLAGS="${CFLAGS}" install
cd ${D}${libdir}
ln -s liblmdb.so.${PV} liblmdb.so
rm liblmdb.a