aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-12-06 18:54:53 +0100
committerKhem Raj <raj.khem@gmail.com>2023-12-07 14:25:11 -0800
commit0cda5a8fb9fb5bc309ba470fceccf65e8bd121d2 (patch)
treeed6102d620b981e7c2d1aee0fbde396d11fd4128 /meta-oe/recipes-crypto
parent61cd30fc786fe95c47ca59e800224382d3bd763e (diff)
downloadmeta-openembedded-contrib-0cda5a8fb9fb5bc309ba470fceccf65e8bd121d2.tar.gz
monocypher: pass LIBDIR to fix installed-vs-shipped QA issue with multilib
* fixes: ERROR: monocypher-4.0.2-r0 do_package: QA Issue: monocypher: Files/directories were installed but not shipped in any package: /usr/lib/libmonocypher.so /usr/lib/libmonocypher.so.4 /usr/lib/libmonocypher.a /usr/lib/pkgconfig /usr/lib/pkgconfig/monocypher.pc Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. monocypher: 5 installed and not shipped files. [installed-vs-shipped] this only fixes the above issues, to make it usable with other libdir values the .pc files would need to be fixed to respect passed LIBDIR value as well as now they expect just lib: monocypher.pc:libdir=${exec_prefix}/lib tests/speed/libhydrogen.pc:libdir=${exec_prefix}/lib Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-crypto')
-rw-r--r--meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb b/meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb
index 899638161a..e6380d9a20 100644
--- a/meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb
+++ b/meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb
@@ -11,8 +11,8 @@ SRCREV = "0d85f98c9d9b0227e42cf795cb527dff372b40a4"
S = "${WORKDIR}/git"
-CFLAGS+="-pedantic -Wall -Wextra -O3"
-EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'CFLAGS=${CFLAGS}'"
+CFLAGS += "-pedantic -Wall -Wextra -O3"
+EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'CFLAGS=${CFLAGS}' 'LIBDIR=${libdir}'"
do_compile() {
oe_runmake library