aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@microsoft.com>2020-10-21 17:55:52 +0100
committerKhem Raj <raj.khem@gmail.com>2020-10-21 14:11:09 -0700
commit993c8cfbc9da4db07a38ae12a9ee6ee0ecae9d4e (patch)
treea3ac69dfbd9e3d5309168590ed5128ed711b9824 /meta-oe/recipes-crypto
parent7839164921ddb340a1bff322a1274c6022cb8565 (diff)
downloadmeta-openembedded-contrib-993c8cfbc9da4db07a38ae12a9ee6ee0ecae9d4e.tar.gz
Add recipe for fsverity-utils
Library and command-line tool to manage the fs-verity feature, introduced in Linux 5.4 and supported in ext4 and f2fs filesystems. https://www.kernel.org/doc/html/latest/filesystems/fsverity.html Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-crypto')
-rw-r--r--meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.2.bb b/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.2.bb
new file mode 100644
index 0000000000..4d5dbafb34
--- /dev/null
+++ b/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.2.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Userspace utilities for fs-verity"
+DESCRIPTION = "fs-verity is a Linux kernel feature that does transparent \
+on-demand integrity/authenticity verification of the contents of read-only \
+files, using a hidden Merkle tree (hash tree) associated with the file. The \
+mechanism is similar to dm-verity, but implemented at the file level rather \
+than at the block device level."
+HOMEPAGE = "https://www.kernel.org/doc/html/latest/filesystems/fsverity.html"
+SECTION = "console"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bc974d217b525ea216a336adb73e1220"
+
+SRCREV = "406187bb3a885e083b448b2c2aa42c22957ae629"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/fsverity-utils.git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "openssl"
+
+EXTRA_OEMAKE += "PREFIX=${prefix} USE_SHARED_LIB=1"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+PACKAGES =+ "libfsverity"
+FILES_libfsverity = "${libdir}/libfsverity*${SOLIBS}"
+
+BBCLASSEXTEND = "native nativesdk"